MP3s on server share have different behavior (and icon)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by guldm, Jan 1, 2010.

  1. guldm macrumors newbie

    Joined:
    Jan 1, 2010
    #1
    i have problems adding my mp3s on my mac mini server to my itunes-media on my mbp. but it is not a itunes-question.

    research showed me that when i list the mp3s in finder on my server, the icon shown is shortly the white itunes icon then turns to the black itunes icon. for all my mp3s.

    looking at the same mp3s on my mbp via the share, only the white itunes icon is shown. only for a small amout of mp3s the black icon is shown as well. and exactly these mp3s i can import (add) to itunes on my mbp.

    on the server i can add all mp3s to my media in itunes.

    now i wonder: what is the reason that finder turns the white itunes-icon to a black one? when i know the difference i should be able to solve the problem with itunes....

    configuration: snow leopard server/client, itunes 9.x, all mp3s have idtag-version 2.3
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    The black icon is actually a "default artwork" icon, used when iTunes doesn't know what the album art should be. I know very little about what actually goes on behind the scenes when that icon substitution is made - and it seems like, to me, that knowing these details would help track down your problem. With that in mind... there's some troubleshooting that can be done. Open up Console (in your Utilities folder). Open up a server share containing stubborn MP3 files, and look for messages Finder generated in the Console. Do a search for Finder in the Console application, while viewing All Messages - this is the easiest method.
     

Share This Page