MP4 File with Separate SRT File Does Not Play Forced Subs on AppleTV or Quicktime?

Discussion in 'Apple TV and Home Theater' started by watcurb, Feb 1, 2014.

  1. watcurb macrumors newbie

    Feb 1, 2014
    Hello, I have some ripped movies that are in mp4 format with separate srt subs and when some of the movies have foreign language scenes the forced subtitles in english will not play when viewing in Quicktime or on AppleTV.

    Do I need to combine the srt file to the mp4 file? How do I get the subs to automatically display during the foreign language scenes? Why is the srt file separate from the mp4 and not packaged with it anyway? Lots of questions but I'm new to creating a digital movie library so any help would be appreciated.

    FYI - most of my movies are in this format (mp4 with separate srt) and the srt file is usually not needed as the entire movie is in english but the few that have one scene or two with a foreign language won't show the forced sub and it's bothering me. Would love any suggestions to fix this problem. Thanks!
  2. priitv8 macrumors 68040

    Jan 13, 2011
    Yes, you need to mux the subs into the MP4 file (e.g. with Subler or similar tool) unless you use a program, that understands to look for external subs and mux them into playbak. Like VLC or Beamer.
    Neither iTunes nor QuicTime will attach subs from external file.
    It used to be possible thanks to Perian, but it's defunct in Mavericks.
  3. watcurb thread starter macrumors newbie

    Feb 1, 2014
    priitv8 - thanks, I downloaded Subler and was able to add the srt file to the mp4 along with adding metadata (which is nice) and when playing with Quicktime I now have the option to turn subs on or off, but it is not forcing them during the foreign speaking sections? Is there a setting that I'm missing? Thanks for this suggestion, I think I'm getting closer!
  4. priitv8 macrumors 68040

    Jan 13, 2011
    What if you set the Forced attribute on the correct subs track?
    Plan-B would be to permanenty burn them into picture using software like HandBrake or Submerge? The result will be similar to that of Avatar, where all Navi-language texts were burnt in in yellow letters on screen.

    Attached Files:

  5. watcurb thread starter macrumors newbie

    Feb 1, 2014
    I set the forced option to "some samples are forced" and selected the correct file, but still not showing up in Quicktime automatically?

    Not sure if I'm doing something wrong or if anyone else is having this issue. Won't Handbrake take a long time to re encode the video if I burn it in? I don't really want to do that for all my movies.

    Attached Files:

  6. orpheus1120 macrumors 65816


    Jan 23, 2008
    Update to the latest version of Subler (0.25).

    Name all tracks to the corresponding languages, don't leave them as "unknown". Save and optimize. Play again.

    Your current settings for forced subtitles should work under ver 0.25. If not, set forced track to "All Samples Are Forced" and try again.

    Read the release notes of Subler for more info.
  7. watcurb thread starter macrumors newbie

    Feb 1, 2014
    orpheus1120 - thanks for your help. I checked and I am currently using Subler v. 0.25 and I changed the language to the subtitle track to English and saved and nothing, still no forced subtitles for the foreign language sections. Then I changed to "all samples are forced" and the movie plays with subtitles for all scenes. So at least I know the subtitles work, but I only want the forced ones to play. It's so frustrating.
  8. Ritsuka macrumors 6502a

    Sep 3, 2006
    If you don't mark the forced subtitles lines as "forced" there is no way the Apple TV is going to guess what's forced and what's not…
    You can make two separate tracks, one with the whole subtitles and the other with only the forced one. Or check on the Subler website how to mark some lines as forced.
  9. orpheus1120 macrumors 65816


    Jan 23, 2008
    The whole purpose of a "forced" subtitle track is to allow a certain type of subtitle to show infrequently throughout the movie. Hence it shouldn't contain all the subtitles of the movie, but selective dialogues that are contrastive to the spoken language.

    When I provided the solution to you earlier on, I assumed you understood the concept of adding "forced" dialogues in a subtitle track in Subler. However perhaps I should be a little bit more clearer.

    Keep reading.

    Yes, Ritsuka is right. Taking straight from the horse's mouth! :)

    OP, I assumed you knew the syntax to add forced subtitles in a SRT file. No worries, I will show you how to do it:-

    You may wish to read this for yourself:-

    To quote the wiki:-

    00:00:02,600 --> 00:00:06,600 X1:0 !!!
    <font color="#ffff00">Yellow Forced Text</font>
    More text and <i>Italic text</i> at top.
    00:00:06,800 --> 00:00:10,000
    <font color="#ffff00">More Yellow</font>
    and two line of text at bottom.
    00:00:11.000 --> 00:00:14.000 !!!
    <b>Bold</b> and forced at bottom.
    00:00:15.500 --> 00:00:18.500 X1:0
    <font color="#3333CC">Color, <i>italic</i>!</font>
    - I am <font color="#FF0000"><u>red</u></font>!
    feature supported
    <b> bold
    <i> italic
    <u> underlined
    <font color="#ffccee">
    X1:0 means the subtitle is aligned to the top of the video
    !!! means a forced subtitle
    So basically, add !!! to the subtitles you wish to forced in your SRT file, and choose option "some samples are forced".

    You may use Jubler to edit the SRT file.

    Experiment on, and you will get there.

    Good luck.
  10. watcurb thread starter macrumors newbie

    Feb 1, 2014
    First off, thanks for your help and advice.

    Ok, so my srt files probably do not have the forced command in them? So, I will need to go into all of them and find the forced lines and add !!! with another program (Jubler). This is way too complicated and I can't go through my entire library and do this. Should I have my movie files in another format?
  11. orpheus1120 macrumors 65816


    Jan 23, 2008
    You can do is to search for a SRT with just the forces subtitles from the web.

    Where did you get yours?
  12. cookisey macrumors newbie

    Dec 29, 2014
    From an article on where to get subtitles and how to add subtitles (SRT, ASS, SSA, IDX, and SUB, etc) to MP4 , I learn that:

    Here we list two ways to obtain subtitles for use:

    Method One: download subtitles from special websites like,, etc.

    Method Two: Just extract subtitle from video and then add the extracted subtitle to other video

    Three steps to add subtitles to MP4

    Step 1 Add MP4 to the program

    Step 2 Add SRT to MP4

    Step 3 Starting adding SRT to MP4
  13. CrashCocoB macrumors newbie

    Mar 15, 2015
    Hi there,

    I'm starting to build a MAC-based home theater with the following equipment :

    - Mac Book Pro (to read the iTunes library from the network (NAS))
    - Apple TV 3

    I've started to encode my own DVDs with the following tools:

    - HandBrake : Apple TV 3 profile, original language, local language, local sub (soft sub), local forcer sub (soft sub)
    - Subler : to concert VobSub in Tx3g and fetch meta-data

    I'm also struggling with forced subs.

    I started with a Dragon Ball movie. I extracted audio French, audio jap and subs French. There were no forced subs.

    As a test, I appended "!!!" after each line of the opening and ending song.

    When I reimport the file in Subler, automatically the option was set to "some samples are forces" (it does not do that if I reimport it without the "!!!"). So it's definetly a good sign.

    When I run the movie in QuickTime, I see now both tracks. The first one and the edited one (with the " !!! ").

    The subtitle setting in QuickTime is " automatic (recommended)".

    The issue is that the forced subs don't show up.

    I try to remove the original track and only keep the edited one but nothing changed.

    NB: I also reported this issue on Subler's site.

    A bandicoot.
  14. CrashCocoB, Mar 16, 2015
    Last edited: Mar 17, 2015

    CrashCocoB macrumors newbie

    Mar 15, 2015
    Hi there,

    I did some additional testing this evening and here's the outcome.

    If I choose the option "all samples are forced", then, the subtitle track does not appear anymore in the QuickTime menu (which is logic since everything is forced, there should not be any possibility to enable/disable it).

    However, the "some samples are forced" option is not working. And I confirm that I appended the "!!!" to a few lines like:

    00:01:00,240 --> 00:01:03,516
    le Dieu Dragon,

    00:01:04,120 --> 00:01:10,389
    qui exaucerait alors
    un unique souhait, quel qu'il fût.

    00:01:47,600 --> 00:01:49,909 !!!
    La légende de Shenron

    00:01:50,040 --> 00:01:53,350 !!!
    <i>Attrapons-les ! Les Dragon Ball !</i>

    Did some of you succeed in make this "some samples are forced" option working ?

    A work-around for me is to add a track containing only the forced subtitles and assign it the option "all samples are forced" but I'd like to make it clean and also understand how to make this "some samples are forced" option working...

    ----- EDIT -----

    My issue was that my forced subtitle track was pointing to itself.
    For those who are interested in subtitles in Subler, I've documented all information I gather on this topic here: Guide

Share This Page

13 February 1, 2014