mp4 jerky video / out of sync audio Quicktime

Discussion in 'Digital Video' started by Jiggy1965, Jan 25, 2011.

  1. Jiggy1965 macrumors newbie

    Joined:
    Oct 7, 2008
    #1
    I've downloaded an asf streaming video with vlc player at home and converted it to mp4. It plays fine at home (windows media player). It also plays fine at work on a Apple Tiger 10.4 with VLC Player. When I play it on Quicktime 7.6.4 however, the playback is jerky sometimes. Also the sound isn't always in sync with the images. Why is that?

    I've also tried it with two dvd's I've ripped on this Mac with 4media dvd ripper and converted to mp4 in the process. They play fine in VLC player on the Mac, but there's this jerky playback and out of sync audio.

    Other formats, like avi or mov play fine in Quicktime.

    Can someone explain why my Quicktime has trouble playing mp4 files?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Use VideoSpec (I prefer that, though it hasn't been updated since 11/2009), MediaInfo Mac (10/2010) or MediaInfo (10/2010, there is a Mac OS X version to download, VideoSpec and MediaInfo Mac are using the same library as MediaInfo) to analyse the .mp4 file and attach the report to your next post.

    Btw, what specs does your Mac have?
     
  3. Jiggy1965 thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #3
    I'm using an Intel Mac with 10.4. Quicktime 7.6. Two monitors. Perian and Flip4Mac installed. Here's the list. Plays fine on pc. Plays fine on mac with VLC player. Choppy in quicktime. Happens to all mp4 video's. A avi e.g. plays fine in quicktime.



    *** MediaInfo Mac // Plain text file report
    2011-01-25 15:58:22 +0100
    Information for File: video.mp4

    General / Container Stream # 1
    Total Video Streams for this File -> 1
    Total Audio Streams for this File -> 1
    Video Codecs Used -> AVC
    Audio Codecs Used -> AAC LC
    File Format -> MPEG-4
    Play Time -> 14mn 53s
    Total File Size -> 66.5 MiB
    Total Stream BitRate -> 625 Kbps
    Video Stream # 1
    Codec -> AVC
    Codec (Human Name) -> Advanced Video Codec
    Codec (Container Code) -> avc1
    Codec Profile -> High@L1.3
    Frame Width -> 352 pixels
    Frame Height -> 264 pixels
    Frame Rate -> 25.000 fps
    Total Frames -> 22312
    Display Aspect Ratio -> 4/3
    Interlacement -> Progressive
    Codec Settings (Summary) -> CABAC / 4 Ref Frames
    QF (like Gordian Knot) -> 0.223
    Codec Settings (CABAC) -> Yes
    Video Stream Length -> 14mn 53s 40ms
    Video Stream BitRate -> 518 Kbps
    Video Stream BitRate Mode -> VBR
    Video Stream Size -> 55.2 MiB
    Date of Original Encoding -> UTC 2011-01-20 20:18:42
    Audio Stream # 1
    Codec -> A_AAC/MPEG4/LC
    Codec (Human Name) -> AAC Low Complexity
    Codec (Container Code) -> 40
    Audio Stream Length -> 14mn 52s 922ms
    Audio Stream BitRate -> 100 Kbps
    Audio Stream BitRate Mode -> VBR
    Number of Audio Channels -> 2
    Audio Channel's Positions -> L R
    Sampling Rate -> 44.1 KHz
    Bit Depth -> 16 bits
    Audio Stream Size -> 10.7 MiB
    Date of Original Encoding -> UTC 2011-01-20 20:18:42
     
  4. Jiggy1965 thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #4
    Does this list help identify the problem? I've streamed an asf file at home using a pc and converted it to mp4. I also converted some dvd vob files to mp4. Played all of them on Quicktime 7 on my mac at work and either the playback is choppy, or goes slowly, or the audio is out of sync which I can see when people are talking.

    When I use VLC player there is no problem. I also installed/uninstalled Persian, no effect. Updated flip4mac, no effect.

    Yesterday I streamed an asf at home and played it without converting to mp4. Results is that it plays but frequently pauzes on frames so the video seems to move very slowly.

    Read somewhere that it might be because I use two monitors side by side? Could that be true.

    Or does Quicktime just not play mp4 files as well as VLC does?
     

Share This Page