MPB Retina Magsafe LED Charging Light - Help!!!

Discussion in 'MacBook Pro' started by MPBrCornwall, Apr 11, 2015.

  1. MPBrCornwall, Apr 11, 2015
    Last edited: Apr 11, 2015

    MPBrCornwall macrumors newbie

    Joined:
    Apr 11, 2015
    #1
    MBP Retina Magsafe LED Charging Light - Help!!

    Hi Everyone
    ( Love reading the forum and I'm hoping you can all help with this one because I'm going mad - and just need this clarified!! )

    I have a Brand New MacBook Pro Retina - however something happened on the LED Magsafe Light which I'm not sure if it's normal or not!

    After I've used the MPB for a few hours, I'll plug in the MagSafe Charger - and have to wait 45 seconds for the light to come on - flash green - and then resume it's orange charging status

    If i do it only after maybe 30min / 1 hour of use, ( without the charger plugged in ) - as soon as I plug it in, the green light will come on straight away

    It looks like the MacBook Pro ( New April 2015 ) - when alot of the battery has been used up - or you've been using it for a couple of hours, that initial plug in of the charger can take up to 45 seconds for the LED light to come on?

    IS THIS NORMAL?

    Other times, like stated, I'll plug it in after a short use, and the light will come on straight away - It seems like it also takes 40-45 seconds after the MacBook has been ''sleeping'' for a couple of hours too

    IS THIS NORMAL?? I'm really hoping it is -

    Please help - and put my mind at ease as I'm going nuts worrying -
    The forums' are always so useful - just need to know what's going on

    Thanks for all your replies :)
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    As long as the abttery is charging properly, I wouldn't worry too much about it.
     
  3. ventmore macrumors 6502

    Joined:
    Jul 13, 2008
    #3
    Have you tried resetting the SMC?

    https://support.apple.com/en-gb/HT201295

    That page specifically states that LED issues with the MagSafe adapter could be a symptom of needing a reset.

    "The MagSafe power adaptor LED doesn't appear to indicate the correct activity."
     
  4. MPBrCornwall thread starter macrumors newbie

    Joined:
    Apr 11, 2015
    #4
    Hi
    Thanks for the reply

    Have tried to reset - but it is still taking 40/45 seconds.
    It seems like the longer the battery is worn down between charging - when i'm using it on battery, the longer it takes for the LED light on the mag safe to come on.

    It's worrying because i just need to find out if this is normal - however - after speaking to people they say the wait should take 10 seconds or less???
     
  5. nj-mac-user macrumors 6502

    nj-mac-user

    Joined:
    Jun 1, 2009
    Location:
    New Jersey
  6. ventmore macrumors 6502

    Joined:
    Jul 13, 2008
    #6
    Since the reset didn't work, if it were me, I'd book a genius appointment and get it checked out.
     

Share This Page