MPEG Streamclip on Lion

Discussion in 'Digital Video' started by scouser75, Mar 1, 2012.

  1. scouser75 macrumors 65816

    Oct 7, 2008
    Guys, tearing my hair out hear.

    I need to rip a project from DVD I did a while back. But every time I try to Export the VS file to Quicktime I get the following message "Error: Can't Create The MOV File".

    I'm using the latest version of Lion on an Intel Mac Pro, along with MPEG Streamclip 1.9 3b7.

    I have checked that I have all the MPEG2 Components installed (Apple MPEG2 CODEC.component & Quicktime MPEG2 Component).

    I checked out the MPEG Streamclip website and followed their instructions to install the components again from my Final Cut Studio Disks but when I double click the PKG file from my original Final Cut Studio disk I can't use it as it was for a PowerPC application. I have the upgrade disks for Final Cut Studio 3 but these don't hold the necessary PKG's!

    The thing is, my Quicktime 7 is the PRO version. So, should this not mean that I should be able to convert files using MPEG Streamclip?

    What else can I do?
  2. cgbier macrumors 6502a

    Jun 6, 2011
    Did you open the installer disk with show package content? FCS2 itself was Universal, only the installer was PPC. You should be able to pull the needed files manually into your system.

    Otherwise, you should have them somewhere in your TimeMachine.
  3. scouser75 thread starter macrumors 65816

    Oct 7, 2008
    Thanks cgbier.

    Alas, the codec I need is the MPEG2 Playback codec, which unfortunately is just not showing up even with Show Package Content.

    As for Time Machine - the only back-up I have is Snow Leopard, and that doesn't have it on there :(
  4. martinX macrumors 6502a


    Aug 11, 2009
    The installer of the MPEG-2 Playback Component may refuse to install the component in Lion. Apple states the component is unnecessary in Lion, however MPEG Streamclip still needs it.

    To install the component in Lion, please download MPEG Streamclip 1.9.3b7 beta above; inside the disk image you will find the Utility MPEG2 Component Lion: use it to install the MPEG-2 Playback Component in Lion. The original installer's disk image (QuickTimeMPEG2.dmg) is required.

    The current versions of MPEG Streamclip cannot take advantage of the built-in MPEG-2 functionality of Lion. For MPEG-2 files you still need to install the QuickTime MPEG-2 Playback Component, which is not preinstalled in Lion. You don't have to install QuickTime 7.
  5. scouser75 thread starter macrumors 65816

    Oct 7, 2008
    thanks martinX. I followed those steps yesterday. My problem is that because I have an old FCS along with an upgrade to FCS3, my QuicktimeMPEG2.dmg is on the old FCS disk, which is a Power PC disk. So, using it along with the MPEG Streamclip Beta won't work :confused:
  6. initialsBB macrumors 6502a

    Oct 18, 2010
    You will have to manually install the MPEG 2 components as the Streamclip utility is asking for the installer from the Apple Store purchased MPEG 2 component (which is NOT a part of Quicktime 7 Pro).

    If you put your FCP Studio disk in your mac, you can find the original installer file (not the alias), and right click on it, show package contents, you should find a folder called Packages, and inside that is the QuicktimeMPEG2.pkg. Again, right click show package contents, and find the Archive.pax.gz file which you copy to your desktop. Double click on it to decompress and you have a series of folders with at the end QuickTimeMPEG2.component. Take this file and copy it to where the folder structure shows you: Macintosh HD / Library / Quicktime /
  7. scouser75 thread starter macrumors 65816

    Oct 7, 2008
    Thanks mate. The thing is, I have the QuickTime MPEG2.component in my Quicktime Library. It's the QuickTime 2 MPEG Playback that I need for MPEG Streamclip.
  8. initialsBB macrumors 6502a

    Oct 18, 2010
    Oh sorry, have you tried putting it in System / Library / Quicktime and not in just Library / Quicktime ?
  9. scouser75 thread starter macrumors 65816

    Oct 7, 2008
    Yup. The Quicktime MPEG2.component is in both locations.

    But, am I mistaken in thinking that it's the Playback component that I actually need? Or is it definitely JUST the QTMPEG2 component that is needed for MPEG Streamclip?

    I've emailed the maker of the software but am yet to hear back.
  10. initialsBB macrumors 6502a

    Oct 18, 2010
    Weird, it works on my Lion install. I don't have a playback component, but I just noticed that I also have a QuickTimeMPEG.component as well as QuickTimeMPEG2.component. I just checked and they are ONLY in System/Library/Quicktime and I can open .VOB files with the latest MPEG Streamclip.

    Maybe the version with your FCP is out of date ? I know that Apple updated the component several times ...
  11. cgbier, Mar 2, 2012
    Last edited: Mar 2, 2012

    cgbier macrumors 6502a

    Jun 6, 2011
    Check the version of your installed MPEG2 component. Mine is 1.02 from 5/11/11.
    As Lion contains that component it seem to have overwritten this version on install. I can check my SL iMac (no FCP X) in the office later today what's the old version.

    Later in the day: My 2008 iMac has the same version (1.02), just a different install date.

    So you should be able to pull the component file from your old FCS disks or a TimeMachine b/u.
  12. scouser75 thread starter macrumors 65816

    Oct 7, 2008
    Thanks guys. So, can I still pull this component from my Final Cut Studio 2 disks, which are power pc disks? If so, how?

    Also, do I still need the Quicktime MPEG-2 Playback component for MPEG Streamclip to work?
  13. HentzDynasty, Jun 21, 2012
    Last edited: Apr 15, 2013

    HentzDynasty macrumors newbie

    Jun 21, 2012
  14. DenMurphy macrumors newbie

    Nov 10, 2012
    Worked like a charm! Thanks, I was having a massive problem trying to upload my D7000 vids to the net, so needed to convert them to .mp4 instead of .mov
  15. Tmezz macrumors newbie


    Jul 3, 2017
    --- Post Merged, Jul 3, 2017 ---
    none of this is working. I can't find the necessary MPEG-2 playback component and the firehazardpromotion link didn't work. really frustrating. thanks for any help.

Share This Page