MPlayerX issue

Discussion in 'macOS' started by 3bs, Feb 20, 2012.

  1. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #1
    How can I make it so that video files always play while filling the screen. Currently I have to press the toggle fillscreen button every time.

    I am on 10.7.3 and using version 1.0.13 of MPlayerX
     
  2. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
  3. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #3
    Did you check mplayer preferences for a full-screen setting?
     
  4. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #4
    There's a setting to have it go to full screen as soon as you open a video file but that's not what I'm looking for. I want it to fill the screen like the toggle button does but I want it to do that automatically instead of me having to toggle it for each video I play.
     
  5. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #5
    In preferences, under Video, check "Enter fullscreen when playback starts". I just tested it on a few videos and it is working for me.
     
  6. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #6
    It enters full screen but doesn't fill the screen. I still have to press the toggle button.
     
  7. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #7
    That is odd. What filetypes are you trying to play? I tested mp4 and wmv yesterday. is there anyway you can post a screenshot of the issue?

    My videos expand to fullscreen when testing this, except for the normal side letterboxing for 4:3 video and top/bottom letterboxing for aspects wider than 16:9. I get the complete "Full Screen" display with no UI except the floating video controls. The video is resized to fit the screen. I assume you are going fullscreen and the video is staying the same size in a box in the middle?
     
  8. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #8
    .avi files. Here are two screenshots one with fillscreen on and one without.

    Screen Shot 2012-02-22 at 23.22.47.png

    Screen Shot 2012-02-22 at 23.24.09.png
     
  9. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #9
    I just tried an AVI file (DivX codec) and it worked. Haven't been able to recreate your problem yet :(. I'll poke around and see if I can still, but have you tried un/re-installing it? The version I am using is from the Mac App Store (you can also download it from the mplayerx.org website). I am also on 10.7.3 / 1.0.13.

    Not that it should matter, but just for comparison, which Mac are you using? Integrated Graphics or Discrete? Single or Dual Monitor setup? And if not a laptop, which connector are you using to your monitor (HMDI, mDP to an adapter, etc...)? Sorry we've been no help so far.

    ----------



    EDIT:

    Make sure the video does not have letterboxing burned in to the video. I was able to recreate your problem with a video that had the top/bottom letterboxing as PART of the video. (Black on top and bottom as well as sides) Then fill screen fixed it.

    I don't see an option for that at first glance.
     
  10. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #10

    Later 2010 MBA 11" using it's screen. I opened the same file with vlc and it didn't have letterboxing as you said. Let me try uninstalling and reinstalling. It's ok I appreciate you at least trying :p

    Edit: I uninstalled it by pressing the x on the icon in launchpad and reinstalled through the MAS but it didn't work. All my settings were the same and it even started playing the video from where I closed it. Should I uninstall it by deleting it from the Applications folder to make sure everything is deleted?
     
  11. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #11
    If that doesn't work, try contacting the Author(s) through Mplayerx.org. I did find some optional features at https://github.com/niltsh/MPlayerX/wiki/Some-settings-you-can't-find-in-the-UI , but the only one that looked remotely close is the fullscreen mode one, and I tried that in Extra Options in the preferences and it didn't work :( . It's possible it just isn't a feature (yet).

    ----------

    There may be some preference files still in your Library directory. I don't want to tell you to delete anything from there though... I'm not sure which files are used by MPlayerX.
     
  12. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #12
    On his website he says to report problems to Issue tracker on Google Code but I can't be bothered to use that. Never have before.

    I think this started happening with the latest update. It wasn't like this before
     
  13. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #13
    I agree, it sucks to have to report bugs... but if you don't, you can only hope other people do. For all we know it could be a simple fix in one line of code that he's not aware of.
     
  14. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #14
    I don't mind reporting bugs. I always do but I've never used this google code thing
     

Share This Page