MS-DOS HDD not appearing on new rMBP

Discussion in 'MacBook Pro' started by Joe91, May 2, 2013.

  1. Joe91, May 2, 2013
    Last edited: May 2, 2013

    Joe91 macrumors newbie

    Joined:
    Jul 16, 2009
    #1
    Hey all,

    So I have a Western Digital portable hard drive formatted to MS-DOS which always worked (and still does) on my 2008 MacBook.

    Unfortunately it never appears/mounts on my new Retina MBP though. The hard drive obviously has power as I can feel it spinning, but it isn't visible. Checked Disk Utility and it didn't appear there either.

    Any suggestions?

    Scratching my head on this one!


    [​IMG]
    [​IMG]
     
  2. jafingi macrumors 65816

    jafingi

    Joined:
    Apr 3, 2009
    Location:
    Denmark
    #2
    ML can easily read/write FAT.

    Do you remember to always eject the disk before disconnecting the USB cable?

    Sometimes when it is disconnected without being ejected, OSX cannot read it.
     
  3. Joe91 thread starter macrumors newbie

    Joined:
    Jul 16, 2009
    #3
    The disk has never worked in the new laptop, in my old one I eject it yeah. The old MacBook is still running OS 10.7.5, not that it matters I suppose.
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    Are you plugging it directly into the laptop or a hub? Could it be that the USB that you have it in is not powering it enough.

    I have a drive that if I plugged it into one of my usbs on my hub, it would spin up and I could hear it moving but the symptoms are as you mentioned. It wasn't until I plugged it directly into the laptop.

    My recommendation is to try a different usb port.
     
  5. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #5
    Enable debug Menu in Disk Utility, then in the debug menu choose List all disks, see if it shows up.

    Also, open System Information, locate USB and see if it shows up there.

    What Maflynn said but use a Y USB cord.
     
  6. Joe91 thread starter macrumors newbie

    Joined:
    Jul 16, 2009
    #6
    Cheers.

    I've tried both USB ports (is plugging directly into the laptop), restarting the laptop too - no joy unfortunately!

    ----------

    Didn't even think of that! Tried another Micro B USB 3.0 cable and it works a charm. Interesting.

    The Debug Menu is a cool trick too, thanks for that.

    Appreciate the help all!
     

Share This Page