ms office 2004 slow start up time?

Discussion in 'Mac Apps and Mac App Store' started by jth11688, Aug 4, 2007.

  1. jth11688 macrumors newbie

    Joined:
    Jul 29, 2007
    #1
    i recently got a new mbp 2.2ghz and it has been running very well, however ms office takes much longer to open than i thought it would/should considering the speed of the processor. upon a fresh boot up (restarting the computer), word takes about 15-20 seconds to open and 10 seconds after i have closed it but have not restarted the computer (clearing the temp files in the ram). i was wondering if this is normal. and if not, is it my computer or ms office? thanks for your help.

    also, when i hover my mouse over the menus on the top and move it horizontally to expand all of the menus, the menus lag behind the mouse. is this normal?
     
  2. Aranince macrumors 65816

    Joined:
    Apr 18, 2007
    Location:
    California
    #2
    Its because Office is not a Universal binary. May I suggest NeoOffice?
     
  3. irishgrizzly macrumors 65816

    irishgrizzly

    Joined:
    May 15, 2006
    #3
    I wouldn't be too concerned – it takes the longest of all my programs, longer even then Photoshop. It's just poorly coded.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    As mentioned, it's due to Office running under Rosetta. Office 2008 (coming in January) is UA and should be a lot faster :)
     
  5. devilot Moderator emeritus

    devilot

    Joined:
    May 1, 2005
    #5
    You should probably go to MS' site and make sure you have the latest version/ updates to MS Office. In addition to that, one member made a great suggestion here.
     
  6. jth11688 thread starter macrumors newbie

    Joined:
    Jul 29, 2007

Share This Page