MS Outlook on Fusion - Links to Safari

Discussion in 'Windows, Linux & Others on the Mac' started by silence, Nov 23, 2008.

  1. silence macrumors member

    Joined:
    Jun 1, 2005
    #1
    Howdy all, just a super quick question i'm hoping you could help with... :eek:

    Under the "Default Applications" feature in VMWare Fusion, i've set all hyperlinks to be opened with Safari. This works beautifully, and from Windows Vista if i click on a link it will open it up in Safari... HOWEVER, this fails to happen when clicking a link in Outlook. Instead of using Safari, it opens the link in Internet Explorer within Vista.

    Does anyone know if it's possible to make links clicked in Outlook emails open up in Safari??

    Your help would be much appreciated! This one's driving me nuts...

    Cheers
     
  2. silence thread starter macrumors member

    Joined:
    Jun 1, 2005
    #2
    Anyone :( ?

    I'd also like to open PDF attachments through Adobe via the Mac (host machine) too...
     
  3. jburnett macrumors newbie

    Joined:
    Dec 29, 2009
    #3
    Pdf

    I'm also trying to find a solution to the below. Does any one know how to do this?
     
  4. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #4
    only post on google, lol!

    Silence, anyone, did you find a resolution yet?

    This is really annoying me, but there is really nothing to be googled about the topic. Hoping you have figured something out.
     
  5. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #5
    In Windows 7 you goto control panel, default programs, set default programs and select default host application. Pick "set this program as default" and save. You must also make sure that the vm is set to allow the guest to launch host applications.

    Tested successfully this very morning.

    Cheers,
     
  6. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #6
    Strange

    That is strange because that is exactly what I did with latest VMWare Fusion with XP SP2. Doesn't seem to do anything, Outlook links still open with IE 6 and not with Safari on Mac :(
     
  7. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #7
    It definitely works with Windows 7. I do not see the same setting in my XP SP3 VM. Where in the control panel in XP do you see default applications? Perhaps I'm missing something. Also what version of Outlook are you using?

    Cheers,
     
  8. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #8
    Ok, I got it to work in XP. Press Start, in the right column click on "Set Program Access and Defaults". Mine was set to Custom. I clicked on the drop down arrow and selected Default Host Application and made sure enable access to this program was selected.

    This only works if the current version of VMware Tools is installed in your XP VM. Clicking on web link in Outlook not brings up Safari in OS X.

    Cheers,
     
  9. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #9
    Still doesn't work though?

    I did find that setting earlier indeed and changed it to default host application. When you reopen the screen it is back to custom, but that might very well be ok and just bad ui design.

    Anyway, with that setting enabled and the latest version of VMWare tools, Outlook still opens links in IE6. There is no way to change that?
     
  10. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #10
    I don't know. It worked great for me. Opens safari for any linked file in outlook. I'm running outlook 2007, xp sp3, VMWare fusion 3.x

    cheers,
     
  11. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #11
    Hmm, using outlook 2007, xp sp2, VMWare fusion 3.0.1. Would it be worthwhile to upgrade to sp3? I'm a little weary of making that change because of the decreased performance with every sp.
     
  12. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #12
    Still no luck

    Upgraded to XP SP3, now have:

    XP SP3 (no security patches, but hey...)
    Outlook 2007 (12.0.4518.1014)
    VMWare Fusion 3.0.1
    MacOSX Snow Leopard (10.6.2)

    Links still open in IE6...

    Have set browser to VMWare as you can see here
    [​IMG]
     
  13. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #13
    Have you set VMware Fusion, preferences, default Applications to Safari?

    Cheers,
     
  14. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #14
    Fusion settings

    Yeah, that's definitely the case:

    [​IMG]
     
  15. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #15
    This is what I was looking at:

    Cheers,
     

    Attached Files:

  16. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #16
    safari default

    Yeah, Safari is default browser. I wonder where you find that preferences pane though? I can only find this from the safari settings:

    [​IMG]
     
  17. SunSear macrumors newbie

    Joined:
    Feb 4, 2010
    #17
    Dooooohhh!!

    Wow, that is one weird bit of user interface.

    So the configure button that is below the "Open mac files using windows"- checkbox is not about that option, but about the "Open windows files using mac"-checkbox???

    That completely puzzles me, but it does work ;-)
     
  18. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #18
    I'm glad you finally got it working. It works great.

    Cheers,
     
  19. JB- macrumors newbie

    Joined:
    Aug 11, 2013
    #19
    MS Outlook on Fusion - Links to Safari

    I figured it out for XP running Parallels as VM.
    In your VM you go to [gear] Configure/Application/Web Pages: Open in Mac

    It works perfectly for me :)
     

    Attached Files:

Share This Page