msata ssd not wanting to erase in powerbook g4

Discussion in 'PowerPC Macs' started by boneskid1, Apr 2, 2014.

  1. boneskid1 macrumors member

    Joined:
    Sep 19, 2012
    #1
    so I purchased a msata ssd to 44 pin ide adapter, and a msata ssd.
    after getting everything hooked up and put back together, booted my leopard disk up, went into disk utility to format the drive and it is frozen now.

    Has anyone ever encountered this before, or is the idea a lost cause?
     
  2. yangdh, Apr 3, 2014
    Last edited: Apr 3, 2014

    yangdh macrumors member

    Joined:
    Mar 31, 2014
    #2
    Does your SSD is of SATA3? Is your adapter SATA1-IDE? I found problems of using SATA3 SSD in my G5: the SSD could be recognized but not be formatted. I tried also SATA2 SSD in G5 using built-in SATA ports, and there was no problem. May be there is a compatibility problem of using SATA3 SSD with SATA1.
    I circumvented the problem by using a PCIE-SATA3 card, though I can have only 2.5GBPS instead of SATA3 6GBPS, but at least SATA3 SSD can be used and a faster speed than that of G5's built-in.
     
  3. boneskid1, Apr 3, 2014
    Last edited: Apr 3, 2014

    boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #3
    Alright I realized I did not give enough information for someone to even understand my problem. and that is entirely my fault.

    so.......
    I own a 1.67ghz PB G4 and it had a 2.5" 64gb ssd that was shoved in to the drive bay with a sata to 44 pin adapter. it was working fine and the PB ran just fine, however I wanted more space than the 64gb had to offer, and there was a small bump on the left side where the adapter was pushing against the topcase.

    In my eyes the idea solution was to get a mstata to ide adapter since it would fit in the drive bay without leaving a bump, and I could increase the drive size..... which is what I did i purchased a 240gb msata ssd and a msata to ide adapter.

    after disassembling and reassembling the Powerbook with the new ssd I boot it to the leopard disk and went into Disk utility. Leopard sees the drive as msata ssd, but when I try to format it as Mac os Extended (Journaled) it freezes on "Partitioning" I only let it set for 10 minutes or so, so idk if i actually need to let it sit longer or..... if it's the sata 3 interface holding me back, which if that's the case I will be a bit disappointed.
    I appreciate any help given, and i apologize for the read I did not have time to go into full detail last night.
    Thanks,
    Boneskid1

    Also here is the ssd I bought.
    http://www.amazon.com/MyDigitalSSD-...qid=1396543119&sr=8-1&keywords=my+digital+ssd
    it had good reviews and for the price I figured it was worth a shot
     
  4. grockk macrumors 6502

    grockk

    Joined:
    Mar 16, 2006
    #4
    Return the SSD. it is SATA III and those don't work with the IDE adapters.

    You need an SATA I or II SSD.
     
  5. boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #5
    but.... my 64gb ssd is a sata 3 drive.

    I will mess with it some more when i get home tonight, as I don't have the machine in front of me
     
  6. harrymatic macrumors 6502

    Joined:
    Dec 30, 2013
    Location:
    United Kingdom
    #6
    I had the exact same problem a while back when using a SATA hard drive with an adapter. In my case it was the adapter that was causing Disk Utility to crash when formatting the drive, as there were no problems at all using the same drive with a SATA PCI card.
     
  7. Laterne macrumors newbie

    Joined:
    Feb 1, 2014
    #7
    Just find a SATA to IDE (PATA) adapter featuring the Marvell 88SA8052 chip.

    In my G3 this chip works flawlessly connecting a Samsung 840 EVO SSD to an ACARD 6280M PCI host card.
     
  8. Cox Orange macrumors 68000

    Joined:
    Jan 1, 2010
    #8
    Does the new adapter + SSD work on the original HDD connector (instead of the ODD connector)?
    Does your old SSD work with the new adapter?
    Does your new SSD work with your old adapter?

    Can you try formatting it in a PowerMac (via and additional adaptor) or in an external HDD-case?

    I have a crucial m4 265GB msata-3 drive and I had problems formatting it first, but after trying several times I succeeded. I used a mSATA-SATA adaptor hooked up to a SATA-PCI card in my PowerMac G4.
    After that I connected the drive with a mSATA to IDE adapter to an ibook G4. I did not try, if I can format it inside the ibook.

    But every combination of SSD and adapter will behave differently. Someone who has the same SSD as me and the same adapter had problems under Windows7, but not under XP, so the OS might make a difference here, too.

    For formatting I had to use 10.5 (10.4 not seemed to work), but on the drive itself I installed 10.4.
     
  9. boneskid1, Apr 3, 2014
    Last edited: Apr 3, 2014

    boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #9
    Disk utility doesn't really crash it just stops. I could try to format the drive in my g5 or could I format it in my macbook as well?

    I will try these options once I get home and I greatly appreciate the input
    Thanks,
    Boneskid1

    here is the adapter I purchased and am trying to use, I had intended on putting it in my post above
    http://www.amazon.com/gp/product/B00BPGRKHY/ref=oh_details_o00_s00_i00?ie=UTF8&psc=1

    according to a review at the bottom it uses a Jmicron JMH330 chip, i have no clue what that means, but maybe this is my problem
     
  10. boneskid1, Apr 3, 2014
    Last edited: Apr 4, 2014

    boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #11
    that is what my other adapter is and it worked just fine so..... idk
    I let Disk Utility sit for about 30-40 mins and it never made progress with "Partitioning". i would like to try and format the ssd with another mac, but i lack the cable to connect it. and on top of that even if i format it, it still my not boot.
    i will be on standby while i try on more thing.....
    Thanks,
    Boneskid1


    After trying the old adapter with a spare 128gb ssd i had in the drawer I have determined that it is the adapter causing the issues, so I will order another adapter..... or how ever many it takes to get it working.
    until then I have another question.
    Is there a specific voltage the drive needs to run at? the reason I ask is because you can get 5 or 3.3 volt adapters and if for some strange reason the powerbook required a 3.3 volt drive and the adapter with ssd is 5 volts, it would not work.
     
  11. Cox Orange, Apr 4, 2014
    Last edited: Apr 11, 2014

    Cox Orange macrumors 68000

    Joined:
    Jan 1, 2010
    #12
    @boneskid: you have the same adapter like Laterne?
    You say you have a mSATA SSD, the adapter is for SATA-2,5"-IDE

    For partitioning my mSATA-III SSD in my G4 I used a mSATA-to-SATA adapter that is sold under different names (I have one were it says "RENICE" and another, that doesn't have this.)

    Go to amazon dot com and type "Renice msata to sata adapter" and hit search. You will get results form from different "manufacturers", with prices from 8-40 USD and they all have the same chip and board design.

    --
    The mSATA to IDE adapter for my ibook is http://ecx.images-amazon.com/images/I/51m6SdM4WGL._SX342_.jpg
    This board is also sold from many different manufacturers, though it is the same. For some reason, some of these are advertised 3,3V and others are advertised 5V. I will have a look on mine and tell you the chip model, later.

    Furthermore there is one Chinese that sells the same board, but says:
    "This card can only connect with 1.8'' 3.3v ide interface,if connects with the 2.5'' ide interface ,the chip will be burning" (The item is described as "for Thinkpad".

    But he has that same one with the description "for Laptop" and there he says:
    "Matching with msata ssd solid state hard drive to be 2.5'' ide hard drive interface, and replace your old laptop's 2.5'' ide hard drive"

    I wonder, if there is really something different. You get these two Chinese ones, with the special description I cited, if you type "msata to ide JMT" on Amazon. (But then again, his board is the same like all the others, from how everything is arranged on the board.

    ---
    Finally, this http://www.ebay.com/itm/mini-pci-e-...t=US_Drive_Cables_dapters&hash=item4abb8bc765 has been recommended by other members. When I pointed out, that it looks identical to the ones I have posted above, they said I was wrong, but I can't see the difference.
    Here is the thread about it http://forums.macrumors.com/showthread.php?t=1713886

    Member Intell suggested the board that you have linked a picture to (green with silver case at the sides http://ecx.images-amazon.com/images/I/418bfEoSGVL._SP160,160,0,T_.jpg).

    As I understand it there is
    a) microSATA / µ-SATA, which we do not have (two gaps in SATA Pin-"row") (adapter http://ecx.images-amazon.com/images/I/41ZqLWYhwoL._SX342_.jpg)
    b) msata (miniSATA or mini PCIe) (one gap in SATA Pin-"row")

    Here is a another Board design, that seems to be different than the others, picture http://ecx.images-amazon.com/images/I/51lIuCZlTuL._SY355_.jpg, article http://www.amazon.com/OKEBA-Adapter...2-fkmr1&keywords=Renice+msata+to+sata+adapter (for 1,8" SSDs).

    ---

    Is your mSATA SSD 1,8" or 2,5"?


    EDIT: the one I have in my ibook for my 1,8" mSATA-III SSD has a Marvell20330 chip. It is this one (I posted above): This is the exact article and seller I bought from http://www.amazon.de/Adapter-mSATA-...KYQ/ref=pd_cp_computers_0/279-0974123-2643405 (I notice a detail. Mine has an additional chip between were it says CIO and UI. The picture does not have that. The other adapters that look the same do not have that two.
    This one http://www.amazon.com/Convert-Conve...=1394309197&sr=8-2&keywords=mSATA+adapter+IDE has a small chip there, but it is smaller than mine. When you then look at the third picture of the same article/add (by JMT), you see it with a bigger chip, which is what I have. So the pictures provided on amazon (and ebay) are not exact.

    Since it might be, the pictures will be gone some time and the above is a bit hard to understand, I uploaded pictures of the three versions of the same board that can be seen on the internet.
    1. (white background) without the additional chip, which is used mostly.
    2. (with red background being badly deleted in photoshop) with a small chip, which is used sometimes as a second picture
    3. (pink background) with the big chip, that I have and is used as 3rd picture in the JMT amazon add.

    I could imagine that no1 is how the board looks at the factors and no2 and no3 is, what makes the difference for 3,3V and 5V. Though I don't know.
     

    Attached Files:

  12. boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #13
    as a follow up I have done a bit of investigation on my own hardware before searching for new.

    my old adapter 44 pin to 2.5" sata has a Jmicron jm20330 chip and it works with both my 64gb and my 128gb sata 3 2.5" drives

    the new adpater for the msata to 44 pin has a Jmicron jmh330 that does not work at all.

    so ideally i need to find a msata adapter with the jm20330 chip on it.
     
  13. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #14
    I have a thread with the 44pim IDE to msata adapter. It works flawlessly in my 1.67ghz PowerBook with a 64GB msata SSD.
     
  14. boneskid1, Apr 19, 2014
    Last edited: Apr 19, 2014

    boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #15
    just a bit of an update I purchased a new msata to ide adapter and it formatted the ssd and i am waiting for leopard to finish installing at the moment i will be back with the results.

    In the mean time here is the link for that adapter in case anyone wants one
    http://www.addonics.com/products/adms25ide.php

    i just bought it off of their store and it was here in 3 days



    so it worked! I now have a 220gb ssd in my powerbook.
    i will post a screenshot so everyone has proof, there was small issue the pb got quite hot while installing
     
  15. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #16
    What chipset is that working adapter you have?
     
  16. boneskid1, Apr 19, 2014
    Last edited: Apr 20, 2014

    boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #17
    um no clue actually there was a few numbers on the chipset but that was it.
    however there was a ibm thinkpad forum that listed the chipset so give me a few mins and I can have it for you. I do know that it is not Jmicron


    Found it, here is the link: http://forum.thinkpads.com/viewtopic.php?f=2&t=112081

    a little ways down a forum member says the chipset is this

    [Marvell logo]
    88SA8052-NNC2
    QAG86312
    1318 81P

    he looked it up and found that it only supports a sata 2 bridge but my ssd is sata 3 so..... i am not sure
     
  17. Laterne macrumors newbie

    Joined:
    Feb 1, 2014
    #18
    That's great news!

    So your new Addonics ADMS25IDE adapter does feature the same Marvel chip 88SA8052 I use. This obviously is one of the most versatile chips out there.

    The majority of IDE to SATA adapters availabe only work with transfer speeds up to SATA1 (150 MB/s). The recommended Marvell 88SA8052 chip however is an exception because it allows adapters to accept speeds up to SATA2 level (300 MB/s) and that in combination with most (if not all) SATA2 or SATA3 type SSDs (limiting the latter to SATA2 speed).

    So the question is what max throughput the original PB G4 onbord IDE controller is capable of? Depending on that the bottleneck is not the IDE-SATA adapter but the Powerbook's onboard controller...

    Did you perform disk benchmark tests?
     
  18. boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #19
    No I did not I had just finished installing last night.
    I can run some benchmark tests though, what program do I need to use?
     
  19. Laterne macrumors newbie

    Joined:
    Feb 1, 2014
    #20
    Take this http://xbench.com/ :)
     
  20. boneskid1, Apr 20, 2014
    Last edited: Apr 20, 2014

    boneskid1 thread starter macrumors member

    Joined:
    Sep 19, 2012
    #21
    Alright I will give it a try once I get home this evening

    EDIT: Here they are after running xbench and making sure there were no updates in system update and xbench was the only program running

    Results 50.62
    System Info
    Xbench Version 1.3
    System Version 10.5.8 (9L31a)
    Physical RAM 2048 MB
    Model PowerBook5,9
    Processor PowerPC G4 @ 1.67 GHz
    L1 Cache 32K (instruction), 32K (data)
    L2 Cache 512K @ 1.67 GHz
    Bus Frequency 167 MHz
    Video Card ATY,RV360M11
    Drive Type BP4 mSATA SSD BP4 mSATA SSD
    CPU Test 85.13
    GCD Loop 137.26 7.24 Mops/sec
    Floating Point Basic 53.87 1.28 Gflop/sec
    AltiVec Basic 329.52 13.13 Gflop/sec
    vecLib FFT 96.31 3.18 Gflop/sec
    Floating Point Library 51.36 8.94 Mops/sec
    Thread Test 60.13
    Computation 70.35 1.43 Mops/sec, 4 threads
    Lock Contention 52.50 2.26 Mlocks/sec, 4 threads
    Memory Test 34.25
    System 32.38
    Allocate 279.58 1.03 Malloc/sec
    Fill 37.54 1825.34 MB/sec
    Copy 16.02 330.79 MB/sec
    Stream 36.34
    Copy 38.80 801.48 MB/sec [altivec]
    Scale 38.93 804.26 MB/sec [altivec]
    Add 35.05 746.67 MB/sec [altivec]
    Triad 33.25 711.35 MB/sec [altivec]
    Quartz Graphics Test 76.35
    Line 61.16 4.07 Klines/sec [50% alpha]
    Rectangle 75.28 22.48 Krects/sec [50% alpha]
    Circle 71.13 5.80 Kcircles/sec [50% alpha]
    Bezier 82.41 2.08 Kbeziers/sec [50% alpha]
    Text 103.53 6.48 Kchars/sec
    OpenGL Graphics Test 77.00
    Spinning Squares 77.00 97.67 frames/sec
    User Interface Test 28.74
    Elements 28.74 131.91 refresh/sec
    Disk Test 164.97
    Sequential 104.00
    Uncached Write 143.78 88.28 MB/sec [4K blocks]
    Uncached Write 137.53 77.81 MB/sec [256K blocks]
    Uncached Read 57.19 16.74 MB/sec [4K blocks]
    Uncached Read 148.13 74.45 MB/sec [256K blocks]
    Random 398.73
    Uncached Write 323.35 34.23 MB/sec [4K blocks]
    Uncached Write 252.17 80.73 MB/sec [256K blocks]
    Uncached Read 2013.31 14.27 MB/sec [4K blocks]
    Uncached Read 403.71 74.91 MB/sec [256K blocks]

    sorry for the now long post, I am unsure as to how good this is but.... after everything was finished updating and the underside wasn't as hot as the sun things are looking good
     

Share This Page