.MTS file (from Canon HF-S10) plays in camera, not on desktop

Discussion in 'Digital Video' started by malch, Jun 10, 2009.

  1. malch macrumors 6502

    Jan 20, 2008
    Hi all,
    Don't know if anyone here will know about this, but I thought it would be worth a try.
    When I open my Canon HF-S10 (AVCHD) in Review mode, I can see that I have one video file (I rolled continuously on a speech for approx. 29 minutes). In the camera, this clip plays back just fine, all 29 minutes of it.

    When I connect the Canon to my Mac, this one file has been divided into three files: they're all .MTS files in the STREAM folder in the BDMV folder. They all look the same — they're all 'MPEG Transport Stream' files, the first two are 1.91 GB, the third one is 1.18 GB. That in itself is fine with me... has something to do with a 2GB limit or whatever. My problem is that the middle file doesn't play... I use an app called VideoPier to convert AVCHD files to QuickTime; when I launch VideoPier, it creates thumbnails of the files it can convert; in the case of this file, the thumbnail is a Question Mark.
    I've emailed the makers of VideoPier a couple times, but haven't heard back.
    On a whim, I divided the problem file on the Canon, and then connected the Canon to the computer again. Oddly enough, the new file converted to QT, but was only a few seconds long.
    I realize this is a stretch... but does anyone have any ideas?
    (in case it matters: MacBook Pro, 4GB RAM, 10.5.6, QT 7.5.5, Avid Media Composer 3.1, VideoPier HD 1.2 v.4143)
    cheers, malch
  2. giffut macrumors 6502

    Apr 28, 2003
    Get ...

    ... MPEG streamclip from here: http://www.squared5.com/svideo/mpeg-streamclip-mac.html

    Then open your video file in MPEG streamclip and call the export feature (File/Export Quicktime). Now call the "Compression" option and scroll down to choose the according XDCAM setting: for the Canon´s cine mode, e.g.,´ this would be "Apple XDCAM EX 1080p24".

    Now, open it with Quicktime, and it should play. This file should import into Avid Media Composer, too.
  3. malch thread starter macrumors 6502

    Jan 20, 2008
    Very nice of you to get back to me on this. In the meantime, I ended up going over to the house of a fellow who has a PC and Sony Vegas... this worked. I got the file I so desperately needed, finished my edit and got the project in.
    After the pressure was off, I did some searching, and tried (demo mode) an app called Voltaic. This worked on my Mac, so I may end up buying it.
    But I'll try MPEG-Streamclip first.
    I appreciate the tip.
    Cheers, malch
  4. Groovsonic macrumors regular

    Oct 4, 2002
    Near Chicago, Illinois
    I have the new Canon HFS100 (the same as your camera, only without internal storage). When I want to convert the files quickly and easily, I just connect the camera and open iMovie. It will convert the AVCHD files to quicktime. The trick is that it has to be in the file format that your camera puts it in. So don't try to drag the MTS files into iMovie. Just connect your camera and open iMovie. That should do it.
  5. CHROSK8 macrumors newbie

    Dec 22, 2009
    Im one step behind

    i too have mpeg streamclip for a previous camcorder. my question is, what are the files to covert? when i plus in my hfs10 i have a canon folder and an untitled icon with various things in them...please tell me which one i have to select! (i tried most of them and none work! )

  6. huskyfan macrumors newbie

    Dec 24, 2009
    Streamclip does not read MTS

    I have mts files on my macbook pro that are imported from my Canon HF-10. Streamclip does not read these files.

    When I open Streamclip and click on "open files" it lists my mts files as an option. However, when I click on them, the Streamclip player gives an error reading stating:

    "file open error: unrecognized file type"

    When I try to export to Quicktime I get another error:

    "cant read the frame size"

    Am I doing something wrong?

    BTW...I am able to read the mts files with VLC but it very choppy.

Share This Page