Multi-Touch drag/select not working after sleep

Discussion in 'MacBook Pro' started by dnenciu, Jul 21, 2008.

  1. dnenciu macrumors member

    Joined:
    Oct 4, 2007
    #1
    Hello,

    I have a new Penryn 17" mbp and I am experiencing some weird issues.

    From time to time when it comes back from sleep dragging windows and selecting text with the trackpad no longer works.

    I can double click, single click, two fingers right click ... except the drag and select does not work (it works if I use the button but not with the tap-drag).

    The only solution is to reboot the machine.

    I had multiple mbps (15" CD, C2D, 17" C2D) and never had this type of issue.

    There is nothing weird in the logs.

    I tried everything I can think of:

    checked unchecked drag in conf panel,

    enable disable bluetooth (both usb devices could have conflict) even left BT off.

    deleted hibernate file (could be corrupted).

    reset PRAM, VRAM

    Even reinstalled Leopard from scratch (no backup)

    Nothing works. :(

    I tried to unload/reload trackpad kernel extension but does not work and completly disables the trackpad until reboot.

    I would really hate having to take my new mbp in for repairs especially that I know how they work on them and how long they would keep it.

    Anybody else has this issue or know of a way to reload the trackpad driver so I don't have to reboot every time it happens?

    Thanks.

    Dragos
     
  2. ebayhelp macrumors member

    Joined:
    Jul 21, 2008
  3. dnenciu thread starter macrumors member

    Joined:
    Oct 4, 2007
    #3
    Well it could be a week or a month you never know for sure.

    Is just that there is a chance they scratch it or they do some other stuff to it or even worse they replace it with a refurb. :(
     
  4. dnenciu thread starter macrumors member

    Joined:
    Oct 4, 2007
    #4
    ok found a work around but still no solution. Is definitely a software issue (trackpad driver) could be related to xcode/iphone sdk.

    I see this in the logs:

    19/07/08 12:20:31 AM /usr/libexec/hidd[25] IOHIDEventQueueEnqueue: Error enqueuing memory. (0xe00002e8)

    I just found out that if I do:

    sudo killall hidd

    it restarts the hidd service and the tap-drag select is back.

    at least I don't have to reboot.

    Anybody has an idea why is this happening?
     
  5. ebayhelp macrumors member

    Joined:
    Jul 21, 2008
    #5
  6. Angarok macrumors newbie

    Joined:
    Jan 18, 2008
    Location:
    Sweden
    #6
    Hi Dragos!

    I'm on a Penryn MBP (15"2.4GHz) and I have exactly the same problem, the dragging feature of the trackpad randomly stops working for no apparent reason. I hadn't connected it to being caused by putting the laptop to sleep, but it seems plausible. BTW, thanks for the tip about the workaround.

    Maybe (hopefully) this is a bug that will be fixed by Apple in a coming software update. Is there a way to submit bugs to Apple directly or do we just hope they read these forums really carefully? :)

    //Jonas
     
  7. artfulalibi macrumors newbie

    Joined:
    Aug 6, 2008
    #7
    Same problem

    I my Penryn 17" also developed the same problem today. :mad:

    Anyone know what this is about???
     
  8. beniel09 macrumors newbie

    Joined:
    Apr 20, 2008
    #8
    me too

    i have a 15" 2.4ghz MBP and i experience this problem 2 times within the week and a bout 2-3 month's ago i don't know what's causing the problem but after i put to sleep my mac is downloading a file and itunes,safari,messenger is open.. i don't know if the downloading causes the problem i've been doing that everyday but the trackpad responded well after sleep, but this time its not.
     

Share This Page