Multiple connection-types issues (SMB, SSH, etc.)

Discussion in 'Mac Basics and Help' started by aaairsci, Aug 16, 2013.

  1. aaairsci macrumors newbie

    Joined:
    Aug 16, 2013
    #1
    Note: I was not having any issues connecting to the general internet with WiFi or Ethernet... both were problem free until I started troubleshooting this issue by attempting SSH connections in Safe Mode and Recovery Mode...since then, and restarting, I have to turn off Wifi and turn it back on before I am allowed to connect.

    That said, I have a brand new MBPro running 10.8.4 with all of the updates installed. I am constantly having issues connecting to servers that are required for me to perform my job... and it feels related.

    For Windows servers, SMB connections constantly fail. I will attempt to connect via the Finder GUI -> Go -> Connect to Server... and if I'm lucky, I can usually maintain a slow connection for about 15 minutes max before it freezes and I receive a message informing me that I have been disconnected.

    For Linux servers, I am usually using the built-in terminal and using various types of connections...usually SSH but also SFTP. Here, I am lucky to be on the other server for 5 minutes before it freezes and I get a Write failed: broken pipe message in the Terminal (not even trying to write anything to the server... I've tested it where I don't do anything on the server and I still get the message).

    I have researched this to exhaustion...tried various solutions...but to no avail. It seems like there is a setting *somewhere* that is timing me out, but I have no idea where it is.

    This sucks because I know previous iterations of Mac OS X have worked perfectly with these tools... what is going on now? The point of me getting a Mac was for the dual use of a windows and UNIX interfaces. Hopefully someone has some ideas... thanks!
     
  2. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #2
    The only time I seen that write fail message was when the server I was connected to was rebooted or my connection was down. SSH still works fine in 10.8.4 I routinely am connected for days to weeks at a time there is no timeout setting you should be running into under a default OS X install. As much as I dislike the suggestion I would go for clean install to make sure you did not mess things up with your troubleshooting. Alternatively if you are doing this on wireless then make sure the access point you are connecting to is not junk and disconnecting you all the time..
     
  3. aaairsci thread starter macrumors newbie

    Joined:
    Aug 16, 2013
    #3
    Yeah that's when I've seen it before as well, but so far my internet has been relatively stable minus the few wifi hiccups on startup. No one else is having internet connectivity issues either.

    It is possible I may do a clean install of OS X...but I hope it doesn't get to that. :\
     

Share This Page