Multiple files downloaded with invalid checksums

Discussion in 'MacBook Pro' started by mfrenkie, Jun 24, 2012.

  1. mfrenkie macrumors newbie

    Joined:
    Sep 1, 2009
    #1
    Hello,
    I have two retina MacBook Pros. Since getting them and trying to download software, I've downloaded multiple .DMGs with invalid checksums. Most recently, I downloaded the MacBook Pro (Mid 2012) Update multiple times from each computer using both Chrome and Safari and it took 8 tries before I got a valid copy (each had a totally different checksum). This has also happened when downloading Adobe CS5.5 and CS6 installers directly from Adobe's site.

    I'm not sure if it's related to the rMBPs, my internet connection, my router, or something else.

    Any ideas on how to investigate further?

    Thank you
     
  2. Stetrain macrumors 68040

    Joined:
    Feb 6, 2009
    #2
    Any other computers you could test with?

    Since both of the new MBPs are doing it I would lean towards a router/connection problem at this point, but testing with a computer you know hasn't had problems before would help.
     
  3. jimckimmel macrumors member

    Joined:
    Nov 9, 2009
    #3
    Anyone else seeing this with the rMBP? I've been trying to download two large DMV files (7GB and 13GB) and each time, the download complete but I cant load the images due to invalid checksums. Doesn't seem to impact smaller dmgs, though. Also, I've got the 768GB SSD in my rMBP.

    Thanks!

    Jim
     
  4. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #4
    Have you tried rebooting your computers?
    Have you tried downloading files from other websites?
    Have you tried downloading with a different browser?
    Have you tried downloading from a different computer on the same network?
    Have you tried downloading from your MBPr on a different network?
    Have you tried resetting your modem?
    Have you tried resetting your router?
    Have you verified that your router have the latest version of firmware available?
    Do you have any special network configurations?
    Have you contacted your ISP?
     
  5. jimckimmel macrumors member

    Joined:
    Nov 9, 2009
    #5
    1. Yes, rebooting had no effect.
    2. Yes. Smaller DMGs seems to be okay.
    3. Different browsers are not the issue for me - I was using an Amazon software download program to download the DMG files.
    4. Yes, I had previously downloaded my files (1 - 7GB, 1 - 14GB) on my 2011 13" MBA, on the same network, with no issues.
    5. No
    6. No
    7. No
    8. Yes
    9. No
    10. No
    Ended up just getting the files off of the MBA. I used AirDrop for the 7GB file with no issues, though the 14GB file was too large for AirDrop so I copied it over my WiFI network. Both files copied this way opened fine.
     
  6. Master-D macrumors member

    Joined:
    Jun 16, 2008
    Location:
    London, UK
    #6
    What was the outcome? Did you find a solution or take the MBP retina back? I'm having the same problem. Eventually the download works, but only after trying umpteen times. If it is a hardware issue perhaps there are other performance issues that are not immediately apparent.

    I don't want to take it back if it's an internet / router issue as it takes an age to set up a new one, and I rather like this computer, even though there are so many issues with the retina display and non-compatible web pages / applications. Can't believe photoshop looks dodgy, surely that is one app they should have sorted out before launch?
     
  7. Master-D macrumors member

    Joined:
    Jun 16, 2008
    Location:
    London, UK
    #7
    I was all set to take the computer back to the Apple store as it was within 2 weeks and I didn't want the hassle of genius appointments etc. figured I would swap the computer and try again. As the display is not showing any signs of ghosting and I didn't want to have to go through the whole process of setting it up again I was reluctant but there were so many invalid checksum errors and corrupt file downloads I thought I would have to.

    But...

    I just got the old macbook pro out and tested a few downloads to see if the problem would manifest itself there, and it did on certain files. I was sure therefore it was either an error with the ISP, or my router/time capsule, or some rogue setting I had on that old one and had transferred to the new one.

    Called Virgin Media who initially said they had tested my connection and everything was fine with the internet, I told them it was specifically an issue with corrupt file downloads, not the general internet. He checked something else and told me that there in fact was an error with the server that I am connected to that their technicians are aware of and working on. Apparently has been there for about 7-8 days which would tie up with when the issue started for me.

    I was sure it was the computer so for anyone else with similar trouble, get on the phone to your ISP as in my case, that was the issue. (I hope, will find out in a few days if Virgin fix it or not, after my 2 week return period has finished)...
     

Share This Page