Resolved Multiple instances of applications in "open with"

Discussion in 'macOS' started by TheMaddawg, Jan 24, 2013.

  1. TheMaddawg, Jan 24, 2013
    Last edited: Jan 24, 2013

    TheMaddawg macrumors newbie

    Joined:
    Jan 17, 2013
    #1
    When I right click on a file to use the "open with" function some of the applications are listed more than once. I have tried repairing permissions, restarting my computer, and I searched the web for the problem and only found a couple cases of this before and it was back in 2005, and the solution then was to delete the com.apple.LaunchServices.6B.csstore file and then restart. That file used to be under Hard Drive>Library>caches, but I cannot find that. I know the library folder is hidden in ML so I have actually looked there. I'm running a clean install of OS 10.8.2
     

    Attached Files:

  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    You need to rebuild the Launch Services Database by entering the following command in Terminal, followed by pressing enter.

    Code:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user
    After you do that, relaunch Finder by holding the Option/Alt key down while you right-click the Finder icon on the Dock, then select Relaunch.

    Your Library folders are hidden by default in Lion and ML. To get to your /Library or /Users/yourusername/Library (also known as the ~/Library) folders in Lion and ML:
    • Launch Finder and click Go > Go to Folder and type: /Library or ~/Library
    • Hold the Option key while clicking the Go menu item, which reveals your ~/Library folder in the menu.
    • Make it permanently visible in Finder by entering the following command in Terminal, then press the Enter key:
      chflags nohidden ~/Library​
    • 18 ways to view the ~/Library folder in Lion
     
  3. TheMaddawg thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #3
    Thanks a lot!! That worked.
     

Share This Page