Multiple MBP issues...

Discussion in 'MacBook Pro' started by BlueDev, Apr 30, 2015.

  1. BlueDev, Apr 30, 2015
    Last edited: Apr 30, 2015

    BlueDev macrumors newbie

    BlueDev

    Joined:
    Nov 23, 2014
    #1
    Im using MacBook Pro Mid-2010 (7,1) and I have more issues with it...
    First issue:
    I mentioned is that RAM memory amount is changing... I have 2x2GB but sometimes it's showing 2GB (Same on BootCamp as on the Yosemite)...
    So I opened my MacBook and removed one stick top bank0 and left the other one in bottom bank1... MB started as usual, showing 2GB (as expected)...
    Then I turned off MB and moved same RAM stick into top bank0 and it worked...Done the same with another stick and it' works... I have never changed RAM sticks since I got MB (It's by Samsung - M471B5673FH0-CF8)... So sticks are working individually, but not together... Maybe this is issue from the beggining, but I didn't mentioned it before... Before that I got a problem with wake-up from sleep (on BootCamp and OSX). I've done hard reset to get it work (I think I lost RAM memory after this, not sure..)

    Second issue:
    After all that I got back to Yosemite and started to type my password (starting with uppercase A and rest are the numbers) and it told me that password is incorrect... I tried again again and again (using left shift for first uppercase password letter)... Then I was like OK, so I used capslock-on (...typed) capslock-off and it was correct...I totally forgot that I was unable to login using L-Shift but it happened again while typing something in the browser...
    So I found out that something is wrong between L-Shift and L-Alt (Option key)...

    Check the attachment for example whats actually happening... When I press L-Shift, it is pressing R-Shift (as expected), but also pressing L&R-Alt buttons???!!!
    Screenshot is the same when I press L-Alt (Option key)... Shift=Alt :(
    The right side of the keyboard (R-Shift,R-Alt) and all other buttons on MB are working correctly, so there is only something happening on the left side...
    Right side works, but it's really uncomfortable for my left hand to type without left shift.
    Just to mention that before I got similar issue (alt buttons stuck) and I was unable to type desired letters - I restarted MB and that was gone...

    Ok, preety long topic, but I wanted to explane whats happening... Guys I appreciate every reply that can solve any of those nightmares! Thanks.

    Edit: done PRAM and SMC reset (nothing happened) ; tried switching RAM between slots again and MB is giving -no RAM sound- when in bottom slot (during boot-up)...
     

    Attached Files:

  2. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #2
    It sounds like

    Your keyboard is broken and you are having logic board issues with your RAM. If I had to guess I'd say it has been dropped or bashed one too many times...

    Short of getting it to a repair shop I can't think of anything you can do to help without a diagnosis.
     
  3. BlueDev, Apr 30, 2015
    Last edited: Apr 30, 2015

    BlueDev thread starter macrumors newbie

    BlueDev

    Joined:
    Nov 23, 2014
    #3
    I have hot air soldering station with nice attachments for those RAM slot pins...Do you think is there any chance of fixing that by reflowing solder?
    And about the keybord, how is that possible for keyboard sheet to be damaged while its not exposed to any physical actions? I like repairing everything by myself,so I just wanted to hear your opinions.

    Thanks for reply!
     
  4. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #4
    It may not be the keyboard sheet it may well be connections to the logic board. I must admit my knowledge of components and fixing them is low to non existent mate. Wish I could help as you are getting little response.
     
  5. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #5
    If the solder for the RAM slot pins is the issue, then reflowing the solder may help. The problem may be located somewhere else though.

    The computer is 5 years old now, the key may have just stopped working.
     
  6. BlueDev thread starter macrumors newbie

    BlueDev

    Joined:
    Nov 23, 2014
    #6
    OK I'll try something, so I'll post here if I get something fixed...
     
  7. BlueDev thread starter macrumors newbie

    BlueDev

    Joined:
    Nov 23, 2014
    #7
    OK friends, I didn't mentioned another issue with my wifi...2-3 months ago my wifi stopped working with message "No hardware installed!"...I was so busy so I just bought micro usb wifi adapter to connect to my networks...
    Today I opened MacBook to check whats happening with that...Wifi,Bluetooth and iSight cable is ok and it's connector (I tried another cable)...Later I started checking motherboard circuitry and I found out that one resisto on the other side of logic board is burned (Its going from wifi connector).. Here is the photo in attachment...Now I need help from you guys to find out value of this resistor... If someone is having this MacBook A1278, please measure it for me

    Thanks
     

    Attached Files:

  8. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #8
    Hmmm
    Either you are very unlucky or just age is taking hold on that MBP. I wouldn't expect a solder issue as you said either stick works individually but you seem to get an issue when both sticks are fitted - but then it sounds intermittant in any case.

    Suspect the keyboard has <just> broken, stuff does that sometimes :mad:
     

Share This Page