Multiple SMTP Addresses With Mail.app

Discussion in 'Mac Apps and Mac App Store' started by richgates, Apr 6, 2010.

  1. richgates macrumors newbie

    Joined:
    Apr 6, 2010
    #1
    Hi All,

    I have multiple email addresses that are all being forwarded to my MobileMe account. I have SMTP addresses set up for each of these accounts set up in Mail.app. Everything is working fine, but there is one thing that bothers me I was hoping I could fix.

    When I reply to email that was sent to one of my other accounts, it still defaults to the MobileMe SMTP server for sending the reply. I know I can select the correct SMTP server in the drop down list, but is there any way to get Mail.app to do this automatically? If not, is there an email application that will do this?

    TIA,

    Rich
     
  2. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #2
    In Mail's Preferences, in the Accounts section for each account there is a setting at the bottom where you can set which SMTP server should be used when replying to a message in that account. There is also a checkbox to have that account only use whichever SMTP server you choose in the drop down list.
     
  3. richgates thread starter macrumors newbie

    Joined:
    Apr 6, 2010
    #3
    Hi MacManiac,

    Thanks for the reply but that won't work in my case because I only have a single account in Mail. I am using POP forwarding from my other accounts to my MobileMe account.

    I was hoping that when I would reply to an email that had gone to one of my other accounts but then was forwarded to MobileMe, it would automatically use the correct SMTP server to reply back. It always defaults to what I set it to.

    I figured there might be a workaround or another Mail app that did this.
     
  4. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #4
    Ah OK. Well since you have it setup this way you may be out of luck. An AppleScript might be your only option. I think as far as Mail is concerned it thinks all the mail is coming from your MobileMe account, even though it is not. I think I had a similar problem in the past and never found a workaround so I just setup all my accounts in Mail and then ran a Rule to organize the emails accordingly.
     

Share This Page