Music added in iTunes automatically shows up on iPhone?

Discussion in 'iOS 9' started by Akuratyde, Mar 19, 2016.

  1. Akuratyde macrumors regular

    Feb 7, 2011
    Hi everyone,
    I'm having an issue where any music I add to my iTunes library automatically downloads to my iPhone. I'm concerned about running out of storage space so I'd like to disable this feature but I cannot seem to figure out what's causing it. This only began happening a few weeks ago. I'm on iOS 9.2.1 and I have automatic downloads disabled in the iTunes & App Stores settings.
  2. lagwagon Suspended


    Oct 12, 2014
    Calgary, Alberta, Canada
    Does it have a little phone icon when you view the album? (See circled item in the first image)

    Or does it have a cloud icon with a down arrow? (See circled item in the second image)

    I've never had anything automatically download to my phone when adding something from iTunes.

    Attached Files:

  3. Akuratyde thread starter macrumors regular

    Feb 7, 2011
    It has the phone icon indicating it's been downloaded to the phone for offline listening.
  4. sbailey4 macrumors 68040


    Dec 5, 2011
    settings>itunes & app store turn off the Music switch.
  5. Akuratyde thread starter macrumors regular

    Feb 7, 2011
    I already have that disabled which I mentioned in my original post. It's not just songs purchased from iTunes either. Literally any MP3's I add to iTunes on my computer will automatically download onto my iPhone.
  6. HopefulHumanist macrumors 6502a

    Jan 28, 2015
    Do you have a playlist set to auto download? If the songs added show up in that playlist, they will be downloaded too. Just a guess.
  7. flashflooder macrumors regular

    Oct 14, 2011
    I'm having the same issue since the last software update. It's a bug with the iCloud music library that disregards the "automatically download music" setting when it's turned off. I've seen it discussed on Apple's forums.
  8. Akuratyde thread starter macrumors regular

    Feb 7, 2011
    Thanks for the reply, that's good to know.

Share This Page