Music Albums Not Playing

Discussion in 'Jailbreaks and iOS Hacks' started by drb1992, Jan 25, 2012.

  1. drb1992 macrumors 6502

    drb1992

    Joined:
    Oct 4, 2011
    #1
    I have had my iPhone 4S JB since last week and everything was going fine until a few days ago. For some reason, certain music albums will not play, while others will play perfectly fine. I have restarted the phone and even turned off a lot of things I got from Cydia. I turned off iTunes Match and then synced my phone to iTunes. All of my music would now play, but those same albums that would not play with iTunes Match turned on, had duplicate songs. Whats even more weird is that both copies of the same song would play fine.

    I tried syncing iTunes again but this time I told it to not put any music on my phone, which made the problem come back. There was only 1 copy of each song, but once again, certain albums would not play. I turned iTunes Match back on and the problem persisted. I am just trying to figure out how to fix this problem, so I am coming to you guys for help. One thing that I would like to try is wipe my 4S of all music, which I was unsuccessful doing through iTunes. Is there something I can download from Cydia (preferably free) that will allow me to completely wipe all music from my phone?

    Currently Installed Cydia Packages:
    SBSettings
    AppCenter
    biteSMS
    BlurriedNCBackground
    Five Icon Dock
    inPulse
    LockInfo
    Orange Sliders
    WeeFlashlight
    WeeSearch
    Winterboard
     
  2. drb1992 thread starter macrumors 6502

    drb1992

    Joined:
    Oct 4, 2011
    #2
    I have done a little more messing around and I think I know what happened. When I JB my 4S, all of the songs that I had put on my phone through iTunes (not iTunes match) before the JB are now corrupted/not working. Does anyone know how I can remove these corrupted songs? iTunes isn't detecting the songs, so I am unable to remove them that way. Someone please help me if you can :D
     
  3. duck33 macrumors regular

    Joined:
    Feb 25, 2008
  4. coolhands macrumors regular

    Joined:
    Oct 18, 2011
    #4
    Why couldn't you wipe your iPhone of music? Are you syncing it with iTunes? Turning off sync wipes all music.
    I was having the same problem, one album just would not play. Deleting the album and adding it back fixed it for me.
     
  5. wcdamsch macrumors member

    Joined:
    Dec 13, 2011
    #5
    I had this issue on my 4s and iPad 2. Had to manually delete all music on the devices and re-sync with iTunes. Everything is working fine now.
     
  6. cvam1985 macrumors regular

    Joined:
    Sep 25, 2011
    #6
    Same thing happened to me but was a huge pain because I use Match. What I had to do was erase all music data through Settings>General>Useage, then reboot, and my music was finally all clear and ready to be downloaded.
     
  7. wcdamsch macrumors member

    Joined:
    Dec 13, 2011
    #7
    I fell dumb! I deleted all 200 albums manually based on another post on a fix for this issue! I was not aware you cold wipe all the music with a single swipe. I guess you learn something everyday. Thanks cvam1985!
     

Share This Page