music.app crashes after each song...

Discussion in 'iPod touch' started by burningbright, Dec 26, 2009.

  1. burningbright macrumors regular

    Joined:
    Jul 5, 2008
    #1
    Hello, I've had my 2G iPod Touch for a few months now, and the music player has just recently started to crash after each song. Have tried switching it off, even completely rebooting it, but that doesn't fix the problem. Does anyone have any ideas on how to fix it? Help much appreciated!
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    I recommend restoring the iPod as a new device in iTunes. Pleas keep in mind this will erase all content on the device, but it should all be synced in iTunes anyways. This should fix the problem.
     
  3. burningbright thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #3
    Thanks for the suggestion! If possible I'd rather not restore the system though, as I'd lose all my progress in games and info in data-logging apps, which would be annoying. Has anyone solved this problem without restoring?
     
  4. TraceyS/FL macrumors 68040

    Joined:
    Jan 11, 2007
    Location:
    North Central Florida
    #4
    I don't have anything else for you to try, except a request that you visit apple.com/feedback and let them know you'd like to be able to retain your data when restoring a device. I find this a huge flaw in making it a working PDA, and keep pointing it out.

    I need to do a full restore to get mine replaced (safari crashing), but I have one app that I'm not interested in reentering all that data. They are supposed to be adding backup/restore/export, but man, it's frustrating that apple doesn't give me something so basic.

    Hopefully you can get it working without having to start over.
     
  5. burningbright thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #5
    Thanks for the reply TraceyS, and I'll write to apple with that suggestion! It does seem to be a glaring imperfection in the OS.

    Have managed to lose my problem -- I just re-synced and it seems to be working alright now! Some file can't have synced properly before...

    Sorry to hear about your safari problem, and hope that the app developers add back-up capability very soon.
     

Share This Page