Music app keeps asking for my Apple ID password

iMikeT

macrumors 68020
Original poster
Jul 8, 2006
2,304
1
California
I got my iPhone 5 last week and activated it this past weekend. Of course, I rolled over all of my info from my old iPhone to this one and entered all of my information in the necessary areas including my Apple ID.

Now when ever I go to my music app and try to play something, a popup comes up asking for my Apple ID password and I have no idea why. I usually hit cancel and go along my merry way and be done with it until next time.

So the questions are, why is this happening? What in the music app is my Apple ID needed for? And is there something in System Settings that I have on that constantly needs this info?

Thanks.
 

iMikeT

macrumors 68020
Original poster
Jul 8, 2006
2,304
1
California
Do you use iTunes Match? Or used to but no longer use it but its still enabled?

I have never used iTunes Match or any of the iCloud services. I had been wondering if this has been related to some sort of iCloud service as well.
 

iMikeT

macrumors 68020
Original poster
Jul 8, 2006
2,304
1
California
I would just try logging out of the apple store and iCloud on your phone and log back in.

I don't use the Apple Store app on my iPhone, I have it installed and never have really. And I have never used iCloud on it either. So I'm definitely not logged into either.
 

MonkeySee....

macrumors 68040
Sep 24, 2010
3,858
435
UK
Its to do with Purchased content trying to be downloaded. Make sure you iTunes password is stored and jump on wifi.
 

iMikeT

macrumors 68020
Original poster
Jul 8, 2006
2,304
1
California
Ok. Now my iPhone is receiving notifications from me making purchases on my iMac with iTunes. Grrrrr, Hulk Smash! :mad::mad::mad::mad::mad:
 

kmpoboy2

macrumors 6502
Jul 10, 2010
374
1
Alabama
Ok. Now my iPhone is receiving notifications from me making purchases on my iMac with iTunes. Grrrrr, Hulk Smash! :mad::mad::mad::mad::mad:
Go to the iTunes & App Store section on settings and turn off automatic downloads for apps and music.

That should do the trick.
 

iMikeT

macrumors 68020
Original poster
Jul 8, 2006
2,304
1
California
Go to the iTunes & App Store section on settings and turn off automatic downloads for apps and music.

That should do the trick.

Those settings have always been off but I was still getting those notifications. I guess the best thing would be for me to sign out of and stay signed out of iTunes and App Store. :(
 

RemyLebeau555

macrumors newbie
Mar 3, 2017
1
0
Those settings have always been off but I was still getting those notifications. I guess the best thing would be for me to sign out of and stay signed out of iTunes and App Store. :(
Goto: Settings>App and itunes Stores
Delete the login name. It will stop asking for the password to something you dont use.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.