Music app on lock screen/watch never shows anything playing

chfilm

macrumors 68020
Original poster
Nov 15, 2012
2,081
1,112
Germany
hi,

My music app is freaking me out since ios11.
Whenever I’m playing something, on the lock screen / today view it just always pretends it’s playing nothing.
The same in “now playing” on the Apple Watch.

Anybody else has this problem, or a fix?
 

willmtaylor

macrumors G4
Oct 31, 2009
10,197
7,726
Here(-ish)
Now that I'm on 11.2, this is happening ALL OF THE TIME on my iPhone 7.

I rarely use the Music app, but it's constantly up on my lock screen. Maddening.

A4F20CF0-B12F-4778-8EF9-010C8FCBF37B.png
 

willmtaylor

macrumors G4
Oct 31, 2009
10,197
7,726
Here(-ish)
Have you tried opening and closing the Music app to get rid of it? Does it come back right away or just randomly somehow?
I had tried that as well as several hard resets to no avail.

However, I do believe I isolated the culprit: one of my Safari tabs had a video embedded in it, so Safari kept thinking this was a media file that needed to be resumed. After closing that tab and resetting, the issue has not reappeared.
 
  • Like
Reactions: C DM

mcdeeee

macrumors member
Jun 15, 2010
30
5
I had tried that as well as several hard resets to no avail.

However, I do believe I isolated the culprit: one of my Safari tabs had a video embedded in it, so Safari kept thinking this was a media file that needed to be resumed. After closing that tab and resetting, the issue has not reappeared.
I tried that myself to no avail. I'm sick of seeing it too! Annoying.
 

willmtaylor

macrumors G4
Oct 31, 2009
10,197
7,726
Here(-ish)
I still get this quite regularly. I'm fairly certain it's related to how iOS 11 handles bluetooth devices--specifically when they're no longer connected. I've also noticed that it also drains the battery quite rapidly, as when this occurs, my battery has ZERO "standby" time for the day--only usage time.

I can only hard reset the device to have it behave normally, but it typically comes back same day.

Super annoying.
 

willmtaylor

macrumors G4
Oct 31, 2009
10,197
7,726
Here(-ish)
After restarting my phone yesterday, I did indeed have usage time and standby time again.

I was careful which Bluetooth devices I connected to, and I think I narrowed it down to the Bluetooth receiver in my vehicle.