Music does not show up on 160gb Ipod Classic, help!

Discussion in 'iPod' started by botanycharm, Feb 1, 2011.

  1. botanycharm macrumors newbie

    Joined:
    Feb 1, 2011
    #1
    Hey guys, I have a strange problem with my ipod. So last night, itunes told me that 'the contents of my ipod cannot be read, and the ipod needs to be restored'. So i restored my ipod, and started to transfer music to the ipod. I transfered all of my music, and it looked like all of the files successfully transfered. But when I unmounted my ipod and started looking through the files, it said I had no music! There were no music files, not anything. I plugged it back into my computer, and nothing showed up in itunes. I looked at the data space, and all the music files were in the 'other' category. So the music is on my ipod, but it will not show up on the ipod. I tried to restore the ipod again, and transfer the files again, but still the files do not show up on my ipod. I'm running a Macbook with osx 10.4.11, and all of the software is up to date. HELP!
     
  2. TheNightPhoenix macrumors 6502

    Joined:
    Dec 16, 2005
    #2
    Are you making sure you are transferring through iTunes and not the finder?

    If you click on the iPod from the desktop can you see your music files?
     
  3. botanycharm thread starter macrumors newbie

    Joined:
    Feb 1, 2011
    #3
    thenightphoenix - Yes I am transferring my music files through itunes. Whenever I eject the ipod, none of the music shows up. It just says 'No Music'. I tried looking at the files through senuti, and it can see the music files, so the files are definitely on the ipod, but something in the ipod software just won't add the music files into the ipod system. Does that make sense? I've searched everywhere online, and i've found no answers.
     
  4. botanycharm thread starter macrumors newbie

    Joined:
    Feb 1, 2011
    #4
    OKAY! I think i solved my problem. I think it was a glitch in the latest version of itunes 9. I deleted it, and downloaded an older version of itunes 9, and all my music seems to be transferring correctly and showing up on the ipod. I'll post again if this problem comes back, but for now, it looks like i just got stuck in a strange glitch. thanks though!
     

Share This Page