Music not playing though headphones

robbw7

macrumors newbie
Original poster
Jul 6, 2019
1
0
London
I just got an Apple Watch Series 4, i have my headphones linked to the watch via Bluetooth, when i want to go for a run i say 'Hey Siri, play a jogging playlist' then it starts playing on my iPhone.

Why is this happening? How can i get it playing though my headphones?

Thanks.
 

mk313

macrumors 6502a
Feb 6, 2012
820
351
Not sure why it's happening, although it sounds like Siri is connecting to the phone first. Maybe try using raise to speak or whatever it's called on the watch so you don't have to say Hey Siri. Or alternatively, put a music complication on your watch & then hit that to open the music app & play your jogging playlist.
 

matrix07

macrumors 601
Jun 24, 2010
4,949
1,468
Without a detail of what headphone you’re using we won’t know for sure but it sounds like your headphone still connected to iPhone.
 
  • Like
Reactions: mk313

HDFan

macrumors 68000
Jun 30, 2007
1,508
367
i have my headphones linked to the watch via Bluetooth, when i want to go for a run i say 'Hey Siri, play a jogging playlist' then it starts playing on my iPhone.
Does it work if you turn off bluetooth on your iPhone?
 

mk313

macrumors 6502a
Feb 6, 2012
820
351
Without a detail of what headphone you’re using we won’t know for sure but it sounds like your headphone still connected to iPhone.
That’s a good a
Point. I was assuming that you were using AirPods. But different headphones pair differently. AirPods will switch from Apple device to Apple device automatically. Most other headphones won’t.
 

waw74

macrumors 68040
May 27, 2008
3,157
189
are you lifting your watch, and the screen is already on before you say "hey siri"?

it's possible the headphones are connected to the watch, but the phone hears the command through it's mic, and takes over.
you'll want to put the phone face down, so it ignores the command.

https://support.apple.com/en-us/HT208472
 

perezr10

macrumors 6502a
Jan 12, 2014
996
376
Monroe, Louisiana
A lot of people may not like this suggestion, but I turned off “hey Siri” on my iPhone. Since I use Siri primarily in my watch it stops the phone from taking over. This is what’s happening to the OP.
 

matrix07

macrumors 601
Jun 24, 2010
4,949
1,468
A lot of people may not like this suggestion, but I turned off “hey Siri” on my iPhone. Since I use Siri primarily in my watch it stops the phone from taking over. This is what’s happening to the OP.
On the watch you don’t have to say Hey Siri though so the watch and phone now are never in conflict. You just have to nail the action that launches her, which I did. :D
 

perezr10

macrumors 6502a
Jan 12, 2014
996
376
Monroe, Louisiana
On the watch you don’t have to say Hey Siri though so the watch and phone now are never in conflict. You just have to nail the action that launches her, which I did. :D
Ah, that’s right. So when the OP uses Hey Siri he ensures that his iPhone, and not his watch, picks it up. He needs to flick his wrist and command his music to start without using the magic words Hey Siri.