Music unstable with aptX

Philippe83

macrumors newbie
Original poster
Jan 5, 2015
4
0
Hello,

I've a Mac Book Air 13" with OS X Yosemite.

I managed to connect my audio device, BC Acoustique EX-222.1 amplifier, with aptX audio codec but I've frequent (every few minutes, sometimes more frequent) glitches (holes or slippage) when listening to music.

This phenomenon does not appear with the SBC codec.

I've dowloaded the Bluetooth Explorer from Apple Developper site, as indicated in previous threads, is there a way, through the Bluetooth Explorer to adjust music transmission settings and to avoid these music glitches ?

Thanks in advance.

Philippe (France)
 

b0fh666

macrumors 6502a
Oct 12, 2012
938
736
south
not for aptx, i'm afraid... SBC on the other hand is fully configurable trough BT explorer.

any special reason to use aptx over SBC?
 

b0fh666

macrumors 6502a
Oct 12, 2012
938
736
south
aptX has better sound quality.
well, that's debatable. from what I read the difference is hardly noticeable, and making it work might be more trouble than it's worth :)

SBC can indeed sound crappy, but if you use BT explorer and set the minimum bitrate way high (I use 325kbps) it sounds OK.

cheers
 

b0fh666

macrumors 6502a
Oct 12, 2012
938
736
south
That is, after all, the best way to assess audio quality.
to read about blind tests and wave recreation tests other people did? sure!

for me at least, ears are kinda wasted bc of old age and abuse.

but hey, don't let education get in the way of marketing hype, it hinders progress it seems :D

cheers
 

Philippe83

macrumors newbie
Original poster
Jan 5, 2015
4
0
SBC can indeed sound crappy, but if you use BT explorer and set the minimum bitrate way high (I use 325kbps) it sounds OK.
Thanks for the info about aptX and yes, it was for better sound quality, but the result is crappy :-(

My SBC Codec Options read:
Current/Initial bitpool 40 (value 2 through 64)
Minimum bitpool 2 (value 2 through 64)
Maximum bitpool 64 (value 2 through 64)

I've also streaming options:
Buffer a maximum of 15 (parameter) packets
Device latency 0.0 (parameter)

How can I have your min of 325 kbps ?

Philippe
 

b0fh666

macrumors 6502a
Oct 12, 2012
938
736
south
Thanks for the info about aptX and yes, it was for better sound quality, but the result is crappy :-(

My SBC Codec Options read:
Current/Initial bitpool 40 (value 2 through 64)
Minimum bitpool 2 (value 2 through 64)
Maximum bitpool 64 (value 2 through 64)

I've also streaming options:
Buffer a maximum of 15 (parameter) packets
Device latency 0.0 (parameter)

How can I have your min of 325 kbps ?

Philippe
set it like this :

initial 53
min 53
max 64

reducing the buffer packets to 4 helps with audio sync on games, but it may skip some bits sometimes. for music it does not matter and you can leave it at 15

cheers
 

Philippe83

macrumors newbie
Original poster
Jan 5, 2015
4
0
set it like this :

initial 53
min 53
max 64

reducing the buffer packets to 4 helps with audio sync on games, but it may skip some bits sometimes. for music it does not matter and you can leave it at 15
Thanks again. Will try next week (I'm out of home this week).

Cheers,
Philippe
 

SackJabbit

macrumors member
Aug 21, 2011
75
12
set it like this :

initial 53
min 53
max 64

reducing the buffer packets to 4 helps with audio sync on games, but it may skip some bits sometimes. for music it does not matter and you can leave it at 15

cheers
hi! i just started managed to activate apt-X on my MacBook Air to my Cambridge Audio GO speakers. the sound, well at least to my perceived listening, does sound a lot better than my previous SBS codec/connection - the trebles has more clarity and bass sounds tighter and evident.

however, like Philippe83, there are occasional skips in the audio with the apt-X. i would like to have the option of perhaps a high quality SBS stream as a fallback option, and your insight into the min/max/inital bitpool values have helped; i noticed increasing those values over default has improved SBS quality somewhat, thanks!

may i ask how the values of 53 on the slider bar correspond to 325kbps? just for my knowledge, thanks!
 

b0fh666

macrumors 6502a
Oct 12, 2012
938
736
south
not sure - the bitrate controls go from 2 to 64, the value 53 just happens to correspond to 325 kbps.

bluetooth explorer is still broken on yosemite, so no way for me to currently change that to see what the max bitrate is... but from what i recall trying to force the max bitrate was soundskip city.

another hint - bt audio works like crap if you are also using 2.4ghz wireless - if you are doing that try to disable wifi or move it to 5ghz and see if it solves the skipping with aptx.

cheers
 

lordthistle

macrumors 6502
Feb 29, 2008
407
0
Italy
I hit this post while searching for known problems affecting aptX drivers on the latest MBPs.

I have the same problem as the OP. When I stream music over aptX with my mid 2012 Yosemite MBP, the music is interrupted frequently. However, this MBP has always had some problems: I see the spinning wheel very often, finder is slow (however, the HD seems OK).

If the stream comes from a late 2008 MBP no problems occur, the music flows without any pause (even if this second MBP became incredibly slow with Yosemite).

After reading this post I am not sure any more: do the latest MBP have problems in their hw/sw combination for bluetooth aptX?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.