Music - unwanted background activity

Discussion in 'iOS 8' started by mpavilion, Jul 9, 2015.

  1. mpavilion, Jul 9, 2015
    Last edited: Jul 9, 2015

    mpavilion macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #1
    Something new in 8.4: Battery Usage shows Music using 6% of battery in last 24 hours ("Low Signal"); and 2% in last 7 days ("Background Activity"). I never use the app, and even have Show Apple Music switched off in the Music settings (note: I never even joined the Apple Music trial). There is no option to turn off Background App Refresh for Music.

    This sucks. I left Android (in part) because of stuff like this (processes running in background, eating battery).

    EDIT: I manually "killed" the Music app by swiping it away in the task switcher (it was still there from when I opened it briefly to check things out after the update). Will report back if that makes a difference over the next 24 hrs.
     
  2. Gryfter macrumors 6502

    Gryfter

    Joined:
    Apr 15, 2011
    Location:
    Brooklyn, NY
    #2
    what I did was go to SETTINGS---GENERAL---RESTRICTIONS, turn it on and turn off Apple Music Connect...

    try that...
     
  3. mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #3
    Thanks, will try...
     
  4. mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #4
    FYI -- one of these fixes seems to have done the trick.
     
  5. mpavilion, Jul 29, 2015
    Last edited: Jul 29, 2015

    mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #5
    Aaaagh... it's back (with a vengeance)!!

    WTF... I don't use the Music app!

    IMG_1076.jpg IMG_1077.jpg
     
  6. Gryfter macrumors 6502

    Gryfter

    Joined:
    Apr 15, 2011
    Location:
    Brooklyn, NY
    #6
    reset all settings and then turn off the 2 Apple music settings...

    if not, do a clean install, hardwired through itunes...
     
  7. asv56kx3088 macrumors 6502

    Joined:
    Jun 24, 2013
    #7
    Settings > Music : turn "show Apple music" off
    Settings > general > restrictions: turn "Apple music connect" off
    Done! Enjoy your everlasting battery!
     
  8. mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #8
    Thanks, but already did those things (see above).
     
  9. mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #9
    Thanks, but also ugh... I'll probably just wait until I upgrade my phone in a few months.

    Actually, I did a restart y'day, which seems to have fixed it again (if only temporarily) -- Music has dropped off the "Last 24 Hours" list.
     
  10. mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #10
    This is totally unrelated (and sorry) -- but how do you do that thing where you quote several different people in a single reply? Folks on here do it all the time, but I've never figured it out...
     
  11. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #11
    From what I could tell in a few days of testing on 8.4 before rolling back to 8.3 (while I still could), virtually all third party apps that use audio tie in to Music somehow. Anytime I used a third party music app that wasn't a streaming app like Spotify, Music would pop up in battery usage, even with every Apple Music related function turned off and the app itself kicked out of memory.

    My assumption was that somehow the third party app were required to tie into an API that was managed by the Music app in some fashion. Given Music's heavy battery drain, that wasn't something I was willing to put up with, and was part of the reason I went back to 8.3. Unfortunately, that's not still an option.

    Anyway, it's worth testing a bit to see it the Overcast app you have listed behaves the same way.

    As for multi-quote, it's done by tapping the quote marks in the lower right corner of each post you want to quote, then tapping on the Insert Quotes button that appears below the reply box, on the left side. That button only shows when you have at least one of the quote marks buttons selected already.
     
  12. mpavilion thread starter macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #12
    Many thanks for all this!!
     

Share This Page