Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Cyberius11

macrumors 6502
Original poster
Oct 20, 2011
415
361
When I put an AirPod in, the Apple Music now playing widget pops up on my Lock Screen. If I force close the music app, it won’t show up again for a few hours. At some point when I put my airpod in, the music widget will start to pop up again. I haven’t opened the music app since I closed it.

I’m getting really tired of this. I’m on calls all day and I’m constantly putting my AirPod in and out of one ear. If my phone is in my pocket it’ll randomly start playing. I want to disable this widget.

Any ideas?
IMG_0702.png
 

Morac

macrumors 68020
Dec 30, 2009
2,152
598
You can try disabling “show when listening” under Settings -> Siri & Search under Apple Suggestions. That or scroll down to Apple Music and turn it off for Siri & Search.
 
Last edited:
  • Like
Reactions: Cyberius11

Cyberius11

macrumors 6502
Original poster
Oct 20, 2011
415
361
Thanks, I'll give that a try. Just turned that off.

I also logged a support ticket with Apple, they're saying this is a feature, not a bug. I've never had this happen until recently, so not sure how it's a feature. If it truly is, it's a turd of a feature that I should have the option to disable.
 

Cyberius11

macrumors 6502
Original poster
Oct 20, 2011
415
361
No dice. Still pops up.

It will stop popping up if I force close music. Still pops back up after a few hours, even if I don’t open music or watch videos.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.