Must re-enter WEP password every hour on MB in Wireless Network

Discussion in 'Mac Basics and Help' started by slobizman, Aug 6, 2008.

  1. slobizman macrumors member

    Joined:
    Jun 16, 2008
    #1
    I got a DSL setup with a wireless gateway, with one Macbook and one PC notebook successfully connecting. But there is an irritating problem with the MB. After about every hour of web surfing, or on a new session, it says there is suddenly no connection. Then, we click on Network Diagnostics, select the wireless network, and then enter the WEP password, after which the connection is good again. It does not help to check the box to save to the keychain when entering the password--we've tried it both ways.

    The PC does not have this problem, so I assume it's some setting in the MB I am missing.

    Anyone have an idea?

    Thanks!!!
     
  2. Siron macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #2
    Not really an answer to your question :eek: but you really shouldn't be using WEP encryption as it's easily broken. Use WPA2 instead - it's much more secure.
     
  3. KoolStar macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #3
    If you really don't want to enter passwords at all and still be secure, you could always use MAC filtering.
     
  4. slobizman thread starter macrumors member

    Joined:
    Jun 16, 2008
    #4
    Thanks for the pointers on security. But, I'm using WEP generally, as the wrong term, sorry. The MB is at my daughter's house so I cannot check at the moment, but I'm pretty sure it's WPA2.

    But, my question isn't about security anyway, it's about having to reenter the password all the time. Does someone know the answer to this?

    Is this the right forum for this? I didn't see a networking forum.
     
  5. osiris24x macrumors member

    osiris24x

    Joined:
    Mar 11, 2007
    #5
    Unfortunately this is a pretty common problem, at least under Leopard. The only way I was able to fix it was to trash the networking plist files, run Yasu, and reboot.

    Good luck!
    :)
     
  6. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #6
    I am sorry you are having problems, and also sorry to point out the obvious, but have you checked save password in keychain option?

    You could also try changing the wireless channel that the router broadcasts on. Try 11. I have very good luck with that with my Macs.

    I used to experience dropped connections on channels 2-6.
     
  7. PcBgone macrumors 6502

    PcBgone

    Joined:
    Feb 3, 2008
    #7
    How about reading the OP's post?

    I have this same Issue...and was hoping for a resolution.

    Osiris, how do you trash these files? And what is Yasu? The server was down so couldnt go to the site.
     
  8. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #8
    Wait, is the router set to control the DNS lease? If so, this isnt a Leopard issue, its the issue of settings of the router. DNS lease is like a license for your compute to access the wireless router, sometimes ppl put a lease expiration so that every say 4 hours you have to enter the password again. Also, try toggling the airport on/off. Sometimes it's just a bad connection/weak signal. Hope that helps!
     
  9. slobizman thread starter macrumors member

    Joined:
    Jun 16, 2008
    #9
    I have to check. However, a PC is able to say connected, no problem.
     

Share This Page