Mute on volume F keys with external screen

Discussion in 'MacBook Pro' started by windowstomac, Aug 21, 2013.

  1. windowstomac macrumors regular

    Joined:
    Jun 23, 2011
    #1
    Hi there,

    I've just started using my MBP at a desk with a lovely new Asus monitor. It's connected via Thunderbolt to HDMI, and as the screen has good speakers, I've set the sound output to the screen.

    The problem is that, by default, this disables the mute and volume functions on the F10, F11 and F12 keys, so when I need to adjust the volume, I have to use the fiddly controls on the monitor.

    Does anyone know a way to make the F keys work again for the external sound device. It's surprising me how often I tweak the volume and mute during the working day, and I'd really like the functionality back!

    Any help or Terminal hacks appreciated!

    Many Thanks
     
  2. sarthak macrumors 6502

    Joined:
    Nov 19, 2012
    Location:
    Canada
    #2
    Sound control is disabled on the notebook when connecting to a TV as well.

    - I am not sure if there are any hacks to bypass this.
    - You might also want to consider getting external speakers to connect via 3.5mm Jack.
    - Most monitor speakers are quite weak but from your post it does seem the ASUS monitor has some good speakers.

    This is normal behaviour. Did the monitor come with a remote?
     
  3. windowstomac thread starter macrumors regular

    Joined:
    Jun 23, 2011
    #3
    It's a screen similar to this:

    http://www.amazon.co.uk/MX279H-Wide...77108535&sr=8-1&keywords=asus+silver+monitor\


    They're not the most amazing speakers in the world but they are made by Bang and Olufsen...and sound far better than the MBP speakers. No remote came with the screen.

    I really don't want to use external speakers, as my desk looks lovely and minimalist right now ;-) (Apple key board and magic trackpad!)

    It'll be a shame if I can't sort it...I often meed to mute quickly during the working day...if my wife calls, if the phone rings etc. I'm surprised more people don't find this a problem...
     
  4. sarthak macrumors 6502

    Joined:
    Nov 19, 2012
    Location:
    Canada
    #4
    Try Soundflower, it should let you pass the audio through and allow you to control the volume.
     

Share This Page