MX 518 Gaming Mouse on Aluminum Macbook

Discussion in 'Mac Basics and Help' started by Burghman81, Jul 11, 2009.

  1. Burghman81 macrumors newbie

    Joined:
    Sep 12, 2008
    #1
    So I know that the software is supposed to be fore Windows, but I've read that you can use SteerMouse to map the buttons. However, for starters, when I plug the mouse in it doesn't even move the cursor.

    Thoughts?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    My Logitech G7 is ostensibly Windows-only as well I believe, but it works fine. Do you have a Windows machine you can test it on?
     
  3. Burghman81 thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #3
    No, I don't have a PC. Though I just exchanged it for a Razer Death Adder and it's not working either. I don't get it. Why when I plug it in does it do nothing? Do I need to turn off the track pad or something on my mac?
     
  4. Burghman81 thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #4
    Macbook not recognizing mouse

    When I have a gaming mouse plugged in - Razer DeathAdder - it lights up, but I get no cursor movement and the software says no mouse is plugged in. What's up with my mac?
     
  5. thomahawk macrumors 6502a

    thomahawk

    Joined:
    Sep 3, 2008
    Location:
    Osaka, Japan
    #5
    i run a logitch g5 gaming mouse on my macbook, no problems just the side buttons dont work due to lack of proper software for it. the scroll and everything works however
     
  6. DeusInvictus7 macrumors 68020

    Joined:
    Aug 13, 2008
    Location:
    Kitchener, Ontario
    #6
    Yeah same here, my G5 worked just fine and then I used steermouse to use the side buttons.

    OP, have you tried restarting the computer and then plugging it in? Or shutting down, plugging in, and then turning it back on?
     
  7. QCassidy352 macrumors G4

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #7
    I use an MX518 with my imac and have used it with several other macs as well. Out of the box it did left/right/scroll and sensitivity up/down. With steermouse I can map all of the buttons to do whatever I want (exposé, for games, etc.).

    Sounds like the problem is with your mac. Have you tried both usb ports? Do other usb peripherals work Ok?
     
  8. Burghman81 thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #8
    Yeah, I don't know why it's not friggin working. My flash drive works fine when I plug it in, but it's not recognizing a mouse. Is there something that needs downloaded or updated?
     
  9. Burghman81 thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #9
    So now I finally got it working, but I can't get it to let me use the driver software to bind buttons. Argh.

    Oh, and I'm now using a Razer DeathAdder
     

Share This Page