MX revo problems???

Discussion in 'Mac Accessories' started by carlosbutler, May 1, 2008.

  1. carlosbutler macrumors 6502a

    carlosbutler

    Joined:
    Feb 24, 2008
    Location:
    London City
    #1
    i bought a logitech MX revolution a few days ago, and it was working fine. but the middle mouse scroll thing is now acting up. it is a lot stiffer and wont free scroll for very long, whereas before it did. has anyone else had this probelm with that mouse?
     
  2. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #2
    You can change the setting on the bottom of the mouse. You probably accidentally flipped the switch...
     
  3. carlosbutler thread starter macrumors 6502a

    carlosbutler

    Joined:
    Feb 24, 2008
    Location:
    London City
    #3
    what flip????? the only thing is the on/off button and thats it...:confused:
     
  4. richardsim7 macrumors regular

    richardsim7

    Joined:
    Oct 17, 2007
    #4
    Ask Logitech, their customer service is AMAZING. They'll probably send you a new one for free :)

    -Rich-
     
  5. carlosbutler thread starter macrumors 6502a

    carlosbutler

    Joined:
    Feb 24, 2008
    Location:
    London City
    #5
    indeed their customer service is very top notch. but i doubt they will send me a new £70. if they did it would be very nice, alienware repaired my £1200 (over priced:p) laptop out of the one year warrenty for free, jolly nice of them. wish all comapnies were like that....
     
  6. irontony macrumors member

    Joined:
    Dec 10, 2005
    Location:
    New Zealand
    #6
    I have the same mouse too, and was disturbed also.

    Just press the top wheel button and it will click in - enabling free scrolling/rolling again and vice versa.

    Mine does this everytime OSX boots up - so just "click" the top wheel down and you will be fine
     

Share This Page