MX Revolution died? (im not sure)

Discussion in 'Mac Accessories' started by phuong, Sep 29, 2006.

  1. phuong macrumors 6502a

    Aug 16, 2006
    after i turned my MP off to change the power plug, i changed the mouse's receiver's usb port. when i turned the MP back on, the MX Rev wouldn't work.
    i'm not sure if it's the mouse itself or the receiver, but here's the screenshot of the Logitech control center (yeah i have to use the good old wheel mouse now)

    at first, i thought the mouse was out of battery (which was weird cause it was full just an hour ago) so i went ahead and charged it. it didnt work.
    then i thought probably the receiver was broken and computer didn't recognize it, so i tested it on my laptop (running windows) .. well, when i plugged it in, there was this "pfff" sound indicating that there's a new USB device plugged in. so it wasn't the receiver either.

    im thinking the mouse and receiver probably aren't talking to each other anymore, but i'm not sure. i tried to turn the mouse off and on but that didnt work:(

    any idea/suggestion?
  2. mulletman13 macrumors 6502a


    Jul 1, 2004
    Los Angeles.
    There should be a "Connect" button on the receiver as well as the mouse... try hitting those in succession.
  3. rtdgoldfish macrumors 6502a


    Jul 4, 2004
    Jacksonville, FL
    The MX Revolution doesn't have a connect button as with most other wireless mice.

    Maybe you should try to reinstall the Logitech Control Center?? If it works on another computer, odds are there is nothing wrong with the mouse.

    You could always call Logitech. They are usually pretty good about providing a replacement if the product is indeed defective.
  4. phuong thread starter macrumors 6502a

    Aug 16, 2006
    @rtdgoldfish: the mouse even doesn't work on other computers. if it did, i wouldn't have been so worried.
    im gonna call Logitech customer service for sure. just that i'll have to wait untill Monday to do that. for now, ive absolutely no clue what to do, as there's even no button on either of them to push, except the on/off switch on the mouse which doesn't help much.
  5. phuong thread starter macrumors 6502a

    Aug 16, 2006
    wow, while trying to search for some trouble shooting at, i found out this is apparently a huge issue of the MXR. some people even can't get this mouse to connect. since neither the receiver nor the mouse has a "connect" button like other mice & keyboard, they have this whole weird trick to "simulate" that process. i tried it and got it work after some 20th-ish try:eek:

Share This Page