MX Revolution wont connect

Discussion in 'Mac Basics and Help' started by mikenike192, May 31, 2008.

  1. mikenike192 macrumors regular

    Joined:
    Feb 19, 2008
    #1
    So i got my mx revolution mouse today and charged it up and tried to use it by plugging the usb receiver in the back of my iMac (intel c2d osx 10.5.3) then i turned on the mouse and i got nothing, no movement, no tracking, no clicking. So then I tried to install Logitechs software on their website the LCC and the Connection utility. Still nothing. So then i uninstalled the logitech stuff and tried steer mouse still no function at all. So I finally test this on my windows machines thinking maybe its a Mac issue still tried just plugging it in nothing then installed the windows stuff and still nothing. This is ridiculous. What is going on.
     
  2. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #2
    Well considering the obvious that your mouse has a sufficient charge (check the green charge lamp on the mouse and make sure it lights up when you move the mouse) then I would have to say its a good possibility you have a defective one.

    You should exchange it.
     
  3. ewilson6 macrumors 6502

    Joined:
    Nov 30, 2006
    #3
    After this installation is complete and your computer has restarted, please go to the System Preferences to configure your Mouse, Trackball or Keyboard. If you had any pre-release of this software, your configuration will be reset to factory defaults.

    click on Symbol that says Logitech.


    2 utilities called LCC Connection and LCC uninstaller in your utilities folder will also help you.

    Your mouse isn't the problem, its the operator.
     
  4. mikenike192 thread starter macrumors regular

    Joined:
    Feb 19, 2008
    #4
    I've already tried LCC connection and all that stuff I'm betting its defective based on the fact that i dont get basic function on any of the OS's i try it on (2 xp machines and osx)
     
  5. metalray@mac.co macrumors member

    metalray@mac.co

    Joined:
    Oct 10, 2006
    Location:
    San Diego, California
    #5
    see if your receiver is pared with the mouse. There is a program on the web that will do that. I had to do it wiht my mouse.
     
  6. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #6
    Do the LEDs on the mouse light up when you move it?
     
  7. mikenike192 thread starter macrumors regular

    Joined:
    Feb 19, 2008
    #7
    Yeah they light up so the laser works, i can see it if you find the right angle. So I think the mouse is in working order like when its charged the free spin thing works and all that so I'm considering the receiver is dead
     
  8. mikenike192 thread starter macrumors regular

    Joined:
    Feb 19, 2008
    #8
    Ok its been a week or so and i returned and got another mx revolution i charged it plugged the dongle in installed latest LCC then turned it. LCC detected my mouse but it still wont let me scroll, track or click. This is ridiculous two mouses can't arrive Dead. I must be missing something.
     

Share This Page