MX Revolution won't connect.

Discussion in 'Mac Accessories' started by CharlieKirk, Aug 26, 2008.

  1. CharlieKirk macrumors 6502

    Joined:
    Jun 22, 2008
    #1
    I searched and found one thread, but it was fixed without too much trouble... I am trying to connect, LCC says "No Logitech device found"...

    Anybody have any tips?

    Appreciated

    Charlie
     
  2. CharlieKirk thread starter macrumors 6502

    Joined:
    Jun 22, 2008
    #2
    Logitech Connection Utility, DOES detect it, as in when the usb is out it doesn't give instructions, and when it's in, it does. LCC still doesn't detect the mouse, and the mouse still doesn't do anything.
     
  3. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #3
    I have had on and off again problems with the LCC software, and now use USB Overdrive instead particularly with my MX Revolution (which I would not give up for anything!!). I have no issues after I started to use that.

    Do note though that the LCC software must be UN-installed with either the Logitech installer disk or downloaded driver file (if you have updated the software with a download from Logitech) as it puts some files in some non-standard places.

    You might want to try the demo of the USB Driver/button controller software from http://www.usboverdrive.com/USBOverdrive/News.html and see if that corrects the connection problem as well. I sometimes got the impression with the LCC software that the connection was being made successfully but the software's driver installation was failing to pass results back to LCC, with the resulting display of no connection.

    BTW- even though the current USB Overdrive is dated 2007 it works fine with all Leopard installations at least up to the current 10.5.4.
     

Share This Page