MxTube: Cannot Connect to Socket

Discussion in 'Jailbreaks and iOS Hacks' started by TurboRiceCooker, Sep 14, 2008.

  1. TurboRiceCooker macrumors newbie

    TurboRiceCooker

    Joined:
    Jul 3, 2008
    Location:
    Northern VA
    #1
    I just updated my iPhone 3G to 2.1 jailbroken. I synced everything, didn't restore any backups in iTunes, then I installed all of my old apps I had before. When I try to download some YouTube vids with MxTube I would get this error. I already uninstalled it and reinstalled it a couple of times and I'd still get the error. I have no idea what to do now, I'm pretty sure I don't have to restore it again, cause this was a completely fresh install.

    [​IMG]
    [​IMG]
     
  2. TurboRiceCooker thread starter macrumors newbie

    TurboRiceCooker

    Joined:
    Jul 3, 2008
    Location:
    Northern VA
    #2
    Never mind I fixed it. I SSH'd into my phone and had to force remove a corrupted folder belonging to MxTube and everything works fine now.
     
  3. rtclee macrumors newbie

    Joined:
    Oct 6, 2008
    #3
    Hi, i have got the same problem. Tried restore and repeat the process but it does not help.

    can you advice the step to perform SSH'd to remove the corrupted folder or where to find such guide.

    Thanks in advance
     
  4. TurboRiceCooker thread starter macrumors newbie

    TurboRiceCooker

    Joined:
    Jul 3, 2008
    Location:
    Northern VA
    #4
    I simply went to this directory
    /private/var/mobile/Library/MxTube
    then I deleted the MxT2_socket folder.
    Hope this helps!
     
  5. Cmunny macrumors newbie

    Joined:
    Oct 21, 2008
    #5
    It Doesn't Work!!

    OMG!!! What the hell... i got cyberduck and openssh on my mac and iphone v2.1 and I deleted the socket folder from my iphone, tried it, and it still didn't work so I, for the 3rd time I un-installed and re-installed mxtube and no diff! My mxtube actually doesn't get to the cannot connect to the socket pop up, as soon as I search for videos it crashes and goes to my home screen, it's getting SOOO frustrating! Could someone help me out???
     
  6. aguascal macrumors newbie

    Joined:
    Oct 26, 2008
    #6
    I had the same problem- I think you need to update to 1.5b of mxtube.
    Go into cydia->manage-> manage packages -> mxtube -> modify to update to 1.5b
     
  7. neobond69 macrumors newbie

    Joined:
    Oct 27, 2008
    #7
    Same issue, reinstalled, cleaned; no success

    Hm...
    I reinstalled mxtube with a reboot after every step,
    I removed MxT2_socket

    but with no success... Any more ideas

    Thx
    Andi

    PS: You might also review attached logfile
     

    Attached Files:

    • log.txt
      File size:
      8.6 KB
      Views:
      100
  8. Cmunny macrumors newbie

    Joined:
    Oct 21, 2008
    #8

    Yeah you're right I upgraded my mxtube in cydia and it's working fine now. :D
     
  9. Cmunny macrumors newbie

    Joined:
    Oct 21, 2008
    #9
    Have you tried upgrading mxtube as previously stated? Try that cuz it worked for me...
     
  10. neobond69 macrumors newbie

    Joined:
    Oct 27, 2008
    #10
    I do have v 1.5b installed already, so no upgrade option for me :(

    As I stated out before I also reinstalled quite a few times....

    But to jump in more detailed... It says "error connecting to socket", so why did deleting a symbolic link (obviously towards the socket) helped out?!?!
    Also I think it has to be some rights issue... Just no idea where to fix permission

    Thx for thinking
    Andi
     
  11. Cmunny macrumors newbie

    Joined:
    Oct 21, 2008
    #11
    I dunno man sorry. Have you tried doing a full restore? Yeah it might be some kind of rights issue but like you I don't know how to get through that... Other than that I really don't know what it could be... Good luck.
     
  12. Cmunny macrumors newbie

    Joined:
    Oct 21, 2008
    #12
    have you tried dtunes?

    If you can't figure out what's up with your mxtube dtunes is an alternative. It's close to the same thing, you can stream or download songs, videos, and there's a torrent section that I have yet to look into. it's not as simple but it's still easy to use.
     
  13. neobond69 macrumors newbie

    Joined:
    Oct 27, 2008
    #13
    Yes, dtunes is an alternative!!! But what a pitty not for me cause my 2 yr old son loves his the builder videos ;)

    Thx...

    Hopefully someone will find out a solution for the socket issue with mxtube, the programmer maybe ;)
     
  14. Hardstyle macrumors newbie

    Joined:
    Jan 8, 2009
    #14
    Sorry for bringing this up. Found this thread by Googling and wanted to share this with you guys.

    I had the same problem with my 1st generation iPhone. Problem is that removing the app doesn't delete the Mxtube folder from Library cause of the "socket" file.

    This is how I did it.Removed the Mxtube. Renamed the MxTube folder from the library to Empty and installed Mxtube again. Very simple fix. Dunno about the 3g version though..
     
  15. neobond69 macrumors newbie

    Joined:
    Oct 27, 2008
    #15
    No success

    Tried it... Thanx for the tip, but no success for me :(

    Does anyone know how to show the destination of a symbolic link?? Think there is the problem... MxTube simply doesn't find the dest...

    Also I do download the videos through tooble (on a mac) and put them into iTunes... A simple sync does the rest... But I would appreciate MxTube cause it is simpler when on the road ;)

    Thx
    Andi
     

Share This Page