my 4.2.1 jailbroken iphone 4 cannot restore via itunes

Discussion in 'Jailbreaks and iOS Hacks' started by chub614, Apr 20, 2011.

  1. chub614 macrumors newbie

    Apr 20, 2011
    I have an iphone 4 that was jailbroken at iOS 4.2.1 with redsn0w on a mac. I want to restore my phone so i can upgrade it and re-jailbreak at 4.3.1. When i try to restore on iTunes it gives me this message "The iPhone could not be restored. This device isn't eligible for the requested build."

    Please help..thanks in advance!!!
  2. Xb0xGuru macrumors member

    Jul 28, 2010
    It sounds like you're trying to restore using a TSS server and TU (or similar). Can you confirm that neither are the case? Are you trying a manual restore for instance?
  3. iFiend macrumors 65816

    Feb 28, 2011
    Do you have 4.3.1 blobs saved? Because as far as I know Apple isn't signing 4.3.1 anymore.

    FYI - I went from 4.2.1 to 4.3.1 and my battery life was AWFUL. Since upgrading to 4.3.2 it's better than ever and the JB is running super smooth. While obviously YMMV, I'd suggest just going to 4.3.2 and JB with redsn0w :)
  4. chub614 thread starter macrumors newbie

    Apr 20, 2011
    I'm just trying to do a restore directly through iTunes. I have not tried putting the phone into DFU mode and doing a manual restore.

    also for clarification i'm still on 4.2.1 and i'm trying to get to 4.3.2 which is why i'm trying to restore.

    Thanks again
  5. chub614 thread starter macrumors newbie

    Apr 20, 2011
    I'm on 4.2.1 still..dont know if i have any blobs saved...sorry not too familiar with all these things. Any help will be greatly appreciated.

  6. need2speed94 macrumors newbie

    Apr 21, 2011

    I recently had some restoration issues myself, I think that we both got the same error message (1013) but if we didnt than still try this. what i was told to do was go into my iTunes host file and delete the 2 lines that say "" at the end. if you have no clue what im talking about, this is how you get to that file the easiest way- (on a mac* sorry if you have a PC)

    minimize all windows so that your menu bar says "finder" up in the left hand corner next to the apple emblem, click "go" then "go to folder" then type in "/private" in the box. then click "etc" then scroll down to the file that says "hosts" in there, the last 2 lines should be "" and
    "#" if you havent modified it. now **before** you delete these, i suggest copying them and saving them in a word doc just in case. but to fix your problem just delete those two lines and try restoring.

    hope this helps

  7. westerlu77 macrumors newbie

    Mar 4, 2008
    I have same problems..
    My iPhone 4 was jailbreaked with 4.3.1 and today I was trying to get 4.3.2 but it had no signal and no folders after the backup-copy. So I decided to restore and restart. But I get all the time: this device isn't eligible for the requested build
    What can I do? I need help now as you can see!!
  8. macnfab macrumors regular


    Aug 5, 2009
    NorthEast IN
    i didn't see this thread.. but i am looking to do the same thing.. update to 4.3.2 jailbroken. My iphone 4 is currently on 4.3.1 and i just jailbroke for the first time a few weeks ago using redsn0w. ?? more confused than ever!:confused:
  9. chub614 thread starter macrumors newbie

    Apr 20, 2011

    I went to that host file like you said but i did not see those last two lines like you said. Any ideas? Thanks
  10. honocorp macrumors newbie

    Jul 9, 2011
    4.xx tethered upgrade solution


    Check this:

    The 'hosts' solution certainly works in certain conditions, but not always...

    I found another interesting case and here is the solution.

    If you want to upgrade to 4.3.3 and have an earlier version jailbreak TETHERED, Itunes will not upgrade your device.

    What you need to do is reJailbreak with a UNTETHERED version.
    When the device is UNTETHERED you can upgrade from Itunes. Of course, if you have used an Umbrella before, you also need to clean up the host file.

    Worked for me on both Ipad 1 4.2.1 tethered and Iphone 4 4.2.1 tethered.

  11. Tech Elementz macrumors 6502

    Jul 7, 2011
  12. Tech Elementz macrumors 6502

    Jul 7, 2011
    Have you tried using a PC to restore? Why don't you try getting into pwned DFU mode? That always work when attempting to restore to anything. However, iREB is only for PC users. If you do not have the correct firmware for your iPhone, head over to for iOS 4.3.2. When you are in pwned DFU mode, it should work when restoring... :D
  13. djnatslice macrumors newbie

    Aug 7, 2011
    Hey guys I'm having the same problem with updating. I jailbroke from tethered to untethered but have all of my same jailbroken apps and do not have loader. Not sure if this is a problem, but it is untethered now and doesn't need redsnow to open. I tried to put it into PWND DFU mode through redsnow and it worked, but when I tried to restore the same message came up from before about it unable to restore because of its build... I also went into the host file and this is what I found for my last files...

    # Host Database
    # localhost is used to configure the loopback interface
    # when the system is booting. Do not change this entry.
    ## localhost broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost

    I deleted them from 127 to but it said it couldn't be saved. I'm a total noob at this and have been out of the country for 5 months and would like the update and stop stressing out. Any help would be seriously appreciated. My phone is out of warranty and I'm running out of options here. Thanks a lot for any help everybody.

  14. djnatslice macrumors newbie

    Aug 7, 2011

    Hey I tried putting my iphone into dfu mode to update from 4.2.1 (just unthethered) and tried to delete the number sequences in the hosts folder but it won't let me save it for privilege issues. I went into get info but nothing I've done works. Any help would be appreciated! This phone is stubborn.
  15. labman macrumors 604


    Jun 9, 2009
    Mich near Detroit
    Your answering a thread from April. They probably found a solution. Btw apple stopped signing 4.2.1 long ago so no shsh blobs no 4.2.1 on 3GS and I4
  16. awadeee macrumors 68020


    Jan 21, 2011
    Viper City
    You will need to open notepad as an administrator and then manually go find the 'hosts' file and edit it.

    If that doesn't work try updating iTunes.

Share This Page