My 4 can't get calls

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Revlefty, Mar 2, 2011.

  1. Revlefty macrumors regular

    Joined:
    May 18, 2006
    #1
    So I wake up today to the phone ringing only to find out that I missed about 10 calls before that. The phone won't ring it just goes straight to voicemail with no sign that it rung. I also can't receive text messages. But I can make calls and text messages with no problems. And everything else works fine.

    Any ideas what could be wrong?
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    In one sentence, you say that the phone rings, in the next, you say it doesn't. Which is it?
     
  3. Revlefty thread starter macrumors regular

    Joined:
    May 18, 2006
    #3
    It rung once, nothing before or after.
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #4
    I've had the issue before on my 3G back in the day. Is your iPhone jailbroken?

    To get a temporary fix on the issue you have to dial a GSM code.
     
  5. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #5
    That's what I think it is too. It's possible that you have accidentally dialed one of the GSM codes for Call Forwarding. To cancel, go to Settings>Phone>Call Forwarding. The GSM code to cancel is: Turn off all Call Forwarding: Dial #002#. Press Send.
     
  6. Revlefty thread starter macrumors regular

    Joined:
    May 18, 2006
    #6
    I'm pretty sure now it's an ATT problem and not a phone problem. I was playing around with it a little more today and I swapped sim card with my gf's iPhone 4 and my phone worked fine with her number in my phone, it could get calls, texts and the "waiting for activation" thing on the face time went away. And nothing changed with my number in her phone. So I guess their is a call to ATT in my future.
     
  7. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #7
    I agree, that's why I posted what I did in the previous post... Did you check those things?:rolleyes:
     
  8. Revlefty thread starter macrumors regular

    Joined:
    May 18, 2006
    #8
    Call forwarding was off, but I tried the code and got some errors;

    error performing request
    no network service

    it says "setting deactivation failed" and it says the same thing for;
    voice call forwarding, voice call forwarding, data call forwarding, fax call forwarding, sms call forwarding, and a few others
     
  9. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #9
    Heck, I hoped that was it....Time to call AT&T I suppose.:(
     
  10. Revlefty thread starter macrumors regular

    Joined:
    May 18, 2006
    #10
    I fixed the phone, Thanks James for the help, I turned off my network then tried again and it worked.
     

Share This Page