My Air is not charging

Discussion in 'MacBook Air' started by pod25, Mar 31, 2014.

  1. pod25 macrumors newbie

    Joined:
    Mar 31, 2014
    #1
    My Macbook Air has stopped charging completely.

    Things I have done.
    1: Replaced the battery.
    2: Replaced the charger.

    Neither solved the problem, in fact, it created a problem.
    After changing the battery, the Macbook would not recognise it had a battery, so I reset the SMC and that fixed the not recognising a battery problem.

    I did manage to get it charging which lasted 5 minutes and the macbook was turned off.
    It did the same thing with the replacement charger.

    I,ve since discovered it might be the power port board ?

    Other than that, I'm all out of ideas.
     
  2. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #2
    Yep sounds like the magsafe io board or it could be the ribbon cable connected to it. Therefore try both
     
  3. potvkettle macrumors newbie

    Joined:
    Nov 7, 2012
    #3
    Apple replaced mine under warranty

    I had the same issue on my 2011 Macbook Air 13". Basically, the charger quit charging the battery all of a sudden. I was able to verify the charger, because the charger for my wife's MBP worked fine.

    Took my MBA and charger by the Apple Store, where they verified some sort of quality control issue on my charger (something in the cable part of it, not the charger itself) and replaced it free of charge (no pun intended).

    Thought I'd suggest the same for you. Hope it helps.
     
  4. pod25 thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #4
    Thanks guys.
    For what they cost, I might as well try replacing the magsafe io board, unless someone else has any ideas as to what the problem is ?
     
  5. jamesjingyi macrumors 6502a

    jamesjingyi

    Joined:
    Dec 20, 2011
    Location:
    UK
    #5
    How old is your MacBook? They might just replace it for free if it is a defect in manufacturing. Also, make sure you put all the original components back and make sure it doesn't look like it has been tampered with before you take it back. They don't like people messing with the inside of machines and may well refuse you a replacement.
     
  6. pod25 thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #6
    I bought it second hand and I think it is a 2008/2009
     
  7. pod25 thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #7
    I did some more tests and work today. I tried to remove the Power Port Board, but it would seem someone has already either removed or replaced this, because it wasn't screwed back down properly.
    When I tried to remove the 2 screws holding it on, I couldn't, they were either seriously cross threaded or they had been glued on and would not budge.

    Now the strange thing is. When I reset the SMC and then plug the magsafe charger into MBA, it shows as charging on the connector (turns from green to orange/yellow)
    Now for the stranger part, it will only show as charging for 11 minutes, then returns back to green and will not charge again until the SMC has been reset.
    So, I did this 4 times, so that is now 40 minutes of charge. But when I turn the MBA on, the battery icon shows at 0% battery.

    If I wasn't confused before, I am now.
     
  8. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #8
    How about disconnect the battery, boot up on AC only.
    Then shut down and try a SMC again.
    Then plug the battery back in
    This will force a re-learn that it has a battery
    now it almost sounds like a end of life flaky batt
     
  9. pod25 thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #9
    Good idea, I will try that.
    As for a duff battery, it is a new one, unless I bought a duff ?
     
  10. l.a.rossmann macrumors 65816

    l.a.rossmann

    Joined:
    May 15, 2009
    Location:
    Brooklyn
    #10
    Which of the following is your problem?

    a) Won't recognize charger AT ALL.

    b) Turns on with the charger, but does not charge the battery.

    If it's A, the cable that attaches the DC in board cable to the motherboard can be knocked out very easily. I'm never a proponent of that wishful thinking horsecrap where people go "it's just the cable". Most of the time people say that because they think it'll be a $10 fix. But with the new airs, it very often does just get knocked out. Check it.

    If it's B, there's also a secondary flex cable that goes from the magsafe board to the motherboard. If this cable gets ****ed up, it will turn on with a charger, but not charge the battery, or light up the magsafe.You can replace this by reading the 82* number on the cable(seven digits), and purchase the proper replacement cable.

    In terms of stripped screws, buy some Xcelite 175M. They're $5-$10 online, and do an excellent job at helping you remove stripped screws. Grab it & turn.

    Good luck!
     
  11. pod25 thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #11
    Thanks for that.
    It is B. The magsafe will power the MBA but will not charge. However, the charge light on the magsafe will light up for 11 minutes after I have reset the SMC and it will do this every time ? But no charge has gone into the battery or if it has, the MBA will not recognise the fact that the battery does have a charge.

    I'm normally pretty good at diagnosing problems, but this one has me lost.

    So to recap.
    The battery has been replaced.
    The magsafe power supply has been replaced.
    Someone at some point has either tried to remove or successfully removed the power port board, but did not replace the screws properly which has left the power port board loose and I can not remove those screws, I can only assume they have been glued in for some daft reason.
     

Share This Page