iPhone X My Alarm Did Not Work This Morning

donster28

macrumors 68000
Original poster
Oct 5, 2006
1,614
617
Great White North
Another DST forward and another failed alarm on my iPhone. Has anyone else experienced this today?

I know it’s a Sunday morning and most don’t care but I had to. Can this be another bug?
 
Last edited:


DonnaUGI

macrumors newbie
Mar 12, 2019
2
7
Iphone XR, Iphone 8 and several friends iPhones, all have the bug, doesn't hold the time correct after daylight saving. I tried support and everything they suggested has failed.
 

SisterBlue22

macrumors 6502a
Apr 29, 2015
654
459
Arizona
Sorry, I live in Phoenix, AZ. Arizona does not observe DST.

My alarm went off like normal.
I live in Phoenix as well. However, my phone (XS Max, but I've had this issue with previous iPhones as well over the years) insists on continually flipping itself to the Denver time zone. I reset it, it flips itself back. When I woke up on Sunday morning, my phone time was an hour off. I (once again) turned off the "Set Automatically" toggle and turned it back on, and it reset itself back to Phoenix, and back to the correct time.

Won't be long before I go to make a calendar entry and notice that once again, my time zone is set to Denver. Drives me insane.
 

eyoungren

macrumors Core
Aug 31, 2011
21,263
13,113
ten-zero-eleven-zero-zero by zero-two
I live in Phoenix as well. However, my phone (XS Max, but I've had this issue with previous iPhones as well over the years) insists on continually flipping itself to the Denver time zone. I reset it, it flips itself back. When I woke up on Sunday morning, my phone time was an hour off. I (once again) turned off the "Set Automatically" toggle and turned it back on, and it reset itself back to Phoenix, and back to the correct time.

Won't be long before I go to make a calendar entry and notice that once again, my time zone is set to Denver. Drives me insane.
That's weird. Wonder if it's an iOS bug. I've never had that happen. However, I'm using a 6s+ on 9.0.2 and my clock is set to 24 hour time with my regional language set to UK English. Too many variables there.