My App crashes on startup? Any help?

Discussion in 'Jailbreaks and iOS Hacks' started by DUMBDOG, Oct 30, 2008.

  1. DUMBDOG macrumors newbie

    Joined:
    Oct 29, 2008
    #1
    So I just recently bought Jonathan Zdziarski's book on open iPhone Developement. The problem is, I cannot get any of the example to run on my phone. At first the program would not even show up on the Springboard, but after I installed BossPrefs from Cydia, it shows up.

    Now my problem is that when I touch on the icon to open the program, it zooms up to the screen as if the app is starting, The whole screen goes black (except for the menu bar at the very top) for about a second or two, and then the app will close and return back to SpringBoard.

    The app will compile fine, and I am using the ldid -S command to sign the app, and still no luck. I have tried 3 different examples, and all had the same result. Is there something common that I might be doing wrong? Any help is appreciated. I can post all the commands that I used to compile and put the app on the phone if it is needed. And I can also post the actual code from the examples if it will help figure out the problem. Thanks in advance for any help.
     
  2. DUMBDOG thread starter macrumors newbie

    Joined:
    Oct 29, 2008
    #2
    bump for help. anyone? is there another topic I could post under to get help? the iPhone programming section says for SDK only or I would have tried there.

    how about another forum site I could try for help?
     
  3. omgmelinda macrumors member

    Joined:
    Jul 15, 2008
    #3
    mines doing the same thing on beerpad, pandora, sporttacular, shazam, yelp, younote, weatherbug.

    I was thinking mine might be because I ended the backup earlly. But I dont know. I also am in the same boat and posted a thread. I cant delete a few of mine either. I need the info on them.
     
  4. omgmelinda macrumors member

    Joined:
    Jul 15, 2008
    #4
    I figured it out for me.
    My girlfriend restored her phone back to normal from JB on my computer. Well I forgot to switch to my account before syncing.

    Heres what worked for me.
    Give it a try if anyone else ends up having this problem.

    Go into intunes and go to the applications tab on itunes.(the ones installed on your phone) and click one. It will ask you to log-in and it will authorize the computer. After it authroizes it will say "Your computer is authorized and you have 5 more computer spaces to authorize". Then Sync it up and afterwards give the apps that are crashing another try.

    Worked for me.
     
  5. DUMBDOG thread starter macrumors newbie

    Joined:
    Oct 29, 2008
    #5
    Its not an app that I downloaded from Itunes. Its an application that I wrote (or copied from the book) and compiled using the Open Toolchain and then copied onto my phone using SSH. So I dont think anything involving iTunes would help me. although I could be wrong? Thanks anyways.:)
     

Share This Page