My app works on Snow Leopard but not Leopard... please help =/

Discussion in 'Mac Programming' started by Abrexas, Aug 2, 2011.

  1. Abrexas macrumors member

    Joined:
    Jul 29, 2011
    #1
    This is my first time posting and I am not sure if this is the right place for my question.

    My problem is: I just made a basic mac app (using xcode 3.2.6) on my macbook pro (snow leopard) and I send it to a friend of mine who has a macbook pro running Leopard. When he tried to run the app he got a message saying he could not run it on his version of Mac OS X. Is there something I can do to the program to make it work for him?
    Thanks!
    - Steven French
     
  2. Abrexas thread starter macrumors member

    Joined:
    Jul 29, 2011
    #2
    I found the answer!

    If anyone else was wondering this, it can be solved by click on Targets (Left side of Xcode) > YourProject > Get Info > and under the 'Build' tab change the 'Mac OS X Deployment Target' to whichever version you need (in my case 10.5)

    Hope this helps anyone else with this problem!
     

Share This Page