My Apps Aren't Updating Automatically in the App Store please help

Discussion in 'iPhone' started by Dan50, Nov 23, 2015.

  1. Dan50 macrumors regular

    Joined:
    Apr 11, 2014
    #1
    After updating to the newest iOS on my iPhone, my apps hasn't been updating automatically. What should I do? It didn't have any problems before this.
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
  3. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #3
    Have you checked to make sure that auto updates are enabled (and perhaps disabled and enabled them again)?
     
  4. Dan50 thread starter macrumors regular

    Joined:
    Apr 11, 2014
    #4
    How do I check that? I always use wifi
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
     

    Attached Files:

  6. Dan50 thread starter macrumors regular

    Joined:
    Apr 11, 2014
    #6
    Yes I checked my settings and it's set to automatic but it didn't update it automatically earlier when there were new updates available, what should I do?
     
  7. sunking101 macrumors 603

    sunking101

    Joined:
    Sep 19, 2013
    #7
    Do it manually?:D

    Log out of iCloud, do a 'reset all settings', log back into iCloud, toggle all your menu settings back to your chosen preferences and see if it works then.
     
  8. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #8
    It needs to be on wifi charging and above 50% before any automatic updates will commence
     
  9. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #9
    I don't think it necessarily even works out doing it everyday. So sometimes some updates from a day or two ago won't get updated until a day or two later.
     
  10. Dan50 thread starter macrumors regular

    Joined:
    Apr 11, 2014
    #10
    I remember I hit update thing for iCloud Drive..anyone know if that caused this issue?
     
  11. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #11
    It shouldn't.
     
  12. Dan50 thread starter macrumors regular

    Joined:
    Apr 11, 2014
    #12
    I don't know how to do those steps.
     
  13. sunking101 macrumors 603

    sunking101

    Joined:
    Sep 19, 2013
    #13
    Go into settings, scroll down to iCloud, then scroll to the bottom and select 'sign out'.
    Then exit out of that and still in settings, go to General, scroll to the bottom and select 'reset'. Then choose the top option 'reset all settings'. Your phone will then reboot.

    Next up, go to settings/iCloud and sign back in. Then work your way through the settings menus and put privacy/location and notifications etc back how you like them (or leave them as they are for 'stock' settings).

    *Edit. Sorry, I meant sign out of the App Store. Not iCloud. Settings/App & iTunes Stores/press your Apple email address at the top of the screen and then select 'sign out'.
     

Share This Page