My backlit keyboard won't turn off.

Discussion in 'MacBook Pro' started by Stevamundo, Oct 13, 2011.

  1. Stevamundo macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #1
    Hi,

    Yes I've unchecked the Automatically illuminate keyboard in low light box in keyboard in system preferences.

    I'm on Lion now and just discovered how to make my home library folder visible again, and I was in my preference folder trying to find something like com.apple.keyboard.plst. Sometimes when you put the plst file in the trash and restart your Mac that usually fixes the problem because the Mac makes the whole new plst file. However I didn't see com.apple.keyboard.plst is it there or under a new name???

    Thank you for helping me.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    Have you tried turning on the lights in the room?

    Kidding.

    What happens when you log in as a different user? What happens when you try to change the keyboard brightness? Does your camera work?
     
  3. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #3
    It happens in every account. The backlighting just won't turn off.

    Keyboard brightness? There's an adjustment for that? Where?

    Yes, my camera works.
     
  4. Tiki35 macrumors 6502

    Joined:
    Oct 25, 2009
    Location:
    Nanoose Bay, BC, Canada
  5. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #5
    This sounds like a stupid question, but have you tried the F5 key? :eek:
     
  6. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #6
    The F keys does nothing.

    Please help!

    ----------

    I've also try repairing the permissions. Nope, that didn't work either.
     
  7. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #7
    I hope you know F key isnt just "F" key but stands for function key...

    Its the keys that are lined up with esc and eject keys. F5 and F6 controls brightness.
    [​IMG]
     

    Attached Files:

  8. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #8
    Yes I know that the F keys stands for the function keys and they didn't do anything.
     
  9. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #9
    Does ANYBODY have any clue how I can fix this????
     
  10. EEXOOO macrumors regular

    Joined:
    Aug 1, 2009
    #10
    If you uncheck Automatically illuminate keyboard, it means that it will be turned on permanently.
    Try checking it and adjust the brightness with the Function keys. You can bring it down to nil.
     
  11. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #11
    I unchecked and was still able to turn mine off... OP, do you have the function keys set to run as function keys or to do the things printed on them?
     
  12. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #12
    I've tried everything and simply the backlighting won't turn off.

    My function keys does what's printed on them.
     
  13. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #13
    so you can't adjust the lighting at all? does anything pop up when you pretty the buttons?

    If not, try holding down the fn button then click them and if that doesn't work, try an SMC reset.
     
  14. gorskiegangsta macrumors 65816

    gorskiegangsta

    Joined:
    Mar 13, 2011
    Location:
    Brooklyn, NY
    #14
    1. Go to System Preferences>Keyboard
    2. Uncheck "Use F1, F2, etc... keys as standard function keys"
    3. Uncheck "Automatically illuminate keyboard in low light"
    3. Try F5/F6 keys again
     
  15. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #15
    I have the same problem. I logged a case with apple when they were beta testing 10.7.2. No matter what I do, the keyboard stays lit
     
  16. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #16
    The both of them are/were unchecked.
     
  17. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #17
    This happened when I updated to Lion. I even used the 10.7.2 combo update, thinking this might help. However no it didn't.
     
  18. fr4c macrumors 65816

    fr4c

    Joined:
    Jul 27, 2007
    Location:
    Hamster wheel
  19. Stevamundo thread starter macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #19
    This didn't help either.

    I guess I'll take it to the Apple store.
     

Share This Page