My brand new iPhone 4S won't auto-focus

ronaldcastillo

macrumors 6502a
Original poster
Oct 25, 2009
619
36
I just bought an iPhone 4S last weekend and the camera won't auto-focus well on close up objects. If I press on the screen where I want to focus on it won't focus at all and will be blurry, but the background of the object is focused very well. My iPhone 4S is jailbreaked and I don't want to restore it to bring it into an Apple Store to get the camera fix. Is there anyway I could fix this?
 

george-brooks

macrumors 6502a
Oct 31, 2011
732
16
Brooklyn, NY
Just exactly how close are the objects you are trying to focus on? All optics have a minimum focus distance and while the iPhone is very good in this regard, there is still some inability to focus extremely close. My 4S (non jailbroken) begins to focus at about 6". How close is yours?
 

ronaldcastillo

macrumors 6502a
Original poster
Oct 25, 2009
619
36
I don't go close up on a picture, maybe about 3/4 of a ruler away from the object? The main object is blurry and the background is clear. I tried turning it on/off but it's still the same.
 

digitard

macrumors 6502a
Sep 15, 2004
666
51
Gilbert, AZ
Have you tried tapping on the object on the screen you want to focus on?

It has adjustable focus points via the software.
 

ronaldcastillo

macrumors 6502a
Original poster
Oct 25, 2009
619
36
Yes I do tap on the screen, but it's still blurry. Will apple be able to replace just the lens or will they need to give me a refurbished phone?
 

PaulyD

macrumors 6502
Nov 16, 2010
342
13
UK
It just sounds like your trying to focus too close to the object. Every camera has a minimum focus distance as said above which is why you're seeing the background in focus but not what you want which is closer that it can focus too.

No doubt if you pull the phone back a bit the thing you want in focus will suddenly do so?

If you want to get any closer after this point simply take the picture at the minimum focus distance and crop with a program afterwards
 

TJ61

macrumors 6502a
Nov 16, 2011
811
3
Maybe it's your subject. Try focusing on black printed text on white paper. With my 4s, the print appears in focus at least down to 3" distance.

I assume you are seeing the camera attempting to focus(?).

Regards,
Tom
 

sweetbrat

macrumors 65816
Jun 17, 2009
1,443
1
Redford, MI
I agree, it sounds like you're trying to focus on a subject that's too close. If there does actually turn out to be something wrong with your phone, Apple will replace the phone, not just repair the camera lens.
 

Randman

macrumors 65816
Jul 28, 2008
1,329
9
Jacksonville, Fla
You might have accidently locked in the Auto Focus feature. When you open the Camera app, is there any text in the bottom middle of the frame? In white saying AE/AF Lock?

If so, you can disable it by double tapping the screen. You can re-enable it by a long press on the screen.
 

Rocko1

macrumors 68020
Nov 3, 2011
2,070
4
Hard reset, full restore, tap on back of phone while attempting to focus. I have heard of the lens becoming stuck. The 4s can focus on objects 2-3" away and further.
 

macbookman83

macrumors 6502
Jan 23, 2011
420
0
New York
Test focusing on several objects if you have no luck then head over to the Apple to show them you need a replacement.

Hopefully it doesn't work when you get there so you won't look crazy.
 

pilot1226

macrumors 6502a
Mar 18, 2010
595
13
USA
Did you remove the plastic protective backing from the rear of the phone? It's possible you could have skipped this step in haste to get it into a case.
 

thatdrewguy

macrumors regular
Mar 14, 2009
173
0
You might have accidently locked in the Auto Focus feature. When you open the Camera app, is there any text in the bottom middle of the frame? In white saying AE/AF Lock?

If so, you can disable it by double tapping the screen. You can re-enable it by a long press on the screen.
Thanks for this tip. I didn't know it existed in the iPhone.
 

ronaldcastillo

macrumors 6502a
Original poster
Oct 25, 2009
619
36
The back plastic is completely off, I'm not trying to focus on macro type of photography. I just want a clear image of the food that I eat and such like those but it's not working. I did restore my phone and still has the same issue. By tapping the lens how do I do that?
 

Rampant.A.I.

macrumors 6502a
Sep 25, 2009
579
9
Sounds like you're just holding it too close to whatever you're taking a picture of. And 3/4 of an inch away... That pretty much is macro photography.

I have Camera+ as a replacement to the stock app, and for detail shots you can just zoom in.

I'm not sure why the stock camera app doesn't have a zoom slider.
 

saving107

macrumors 603
Oct 14, 2007
6,376
14
San Jose, Ca
The back plastic is completely off, I'm not trying to focus on macro type of photography. I just want a clear image of the food that I eat and such like those but it's not working. I did restore my phone and still has the same issue. By tapping the lens how do I do that?
Can you post a picture as an example of the subject and the distance that your trying to take the picture, my iPhone 4 can handle close-ups very well within a reasonable amount of distance.


 

DankNugz

macrumors regular
Jan 11, 2012
143
0
Bay Area, CA
Sounds like you're just holding it too close to whatever you're taking a picture of. And 3/4 of an inch away... That pretty much is macro photography.

I have Camera+ as a replacement to the stock app, and for detail shots you can just zoom in.

I'm not sure why the stock camera app doesn't have a zoom slider.
Pinch and expand with 2 fingers and it zooms in and out.
 

Rampant.A.I.

macrumors 6502a
Sep 25, 2009
579
9
Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

Thanks. It's been 2 weeks, I should get around to reading one of the iPhone tips threads, or the product info. Lol.
 

DankNugz

macrumors regular
Jan 11, 2012
143
0
Bay Area, CA
Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

Thanks. It's been 2 weeks, I should get around to reading one of the iPhone tips threads, or the product info. Lol.
You're welcome. There are plenty of small features and stuff like that throughout iOS. It takes awhile to learn most or all of them.
 

PYT1986

macrumors newbie
Jul 30, 2010
8
1
I am having this exact same issue...

I picked up my new iPhone 4S on Thursday, and only opened the camera on the weekend to take pics. It doesn't auto focus. I am not holding it too close to objects, I had the iphone 4 for almost 2 years and am quiet familiar with the camera/focus.

When I touch the screen to focus the lightness/darkness adjusts but no focussing. Googled a bit and have found several people have had this issue. apparently tapping the back of the camera etc fixes it, I have done this but nothing...

Going to call Apple to sort this out, seems like I will need a replacement phone...
 
  • Like
Reactions: Cattlegrl

KSaebin

macrumors newbie
Oct 2, 2010
16
0
I have the exact same issue with my iPhone 4S.
Reset the phone, restored it, but still nothing.
Tried tapping (and hitting) near the camera lens and whatnot all to no avail.

Tap to focus only adjusts exposure level and doesn't do any focusing at all.
Quite a lot of people seem to have this problem but there seems to be no proper way to fix it? I've googled a couple of times and most of the time I see people going for an exchange at the apple store.

Might head down to the store to get a change as well because it's really annoying - the main object can be like 2 palm's distance away but it still wouldn't focus! :mad:
 

roxychicx23

macrumors member
Jul 10, 2008
30
0
It's not you its the phone. I've had the same issue...brought the phone into the genius bar and apple has a camera replacement kit where you keep your original phone. They just switch out the camera. So I did not get a refurbished phone. The camera worked fine for about a month and then it stopped focusing again and I had blurry pictures. So this time they figured it was the phone...they replaced my phone and so far the camera has been working fine.
 

mgiara

macrumors newbie
Mar 28, 2012
3
0
I hope I'm not grave-digging, I just wanted to throw this out there.

Hard reset, full restore, tap on back of phone while attempting to focus. I have heard of the lens becoming stuck. The 4s can focus on objects 2-3" away and further.
I've been taking blurry pictures for about a week now and I've had enough.
I figured I'd try a quick g00gle search before going into the sold out rock concert that is every Apple store I've ever been to. (Also I'm Jailbroken [4S], so I don't want to go through reversing that)
Just wanted to say thanks to Rocko 1, (up-voted his comment)

My lens must've been stuck in a medium range focus because that's all that came out clear.

I gently tapped the back of the phone with one finger, while touching the center of the screen (focus point on an object 9" away), and I could actually Hear the lens focus. The result? A perfectly-focused shot.

I registered here just to thank you!!
Thanks Rocko!!!
 

ellealvaro

macrumors newbie
Sep 22, 2012
1
0
I have the same issue with the iPhone 4s I got last august. My autofocus feature just would not work. Here are 2 images I took with it :

http://i48.tinypic.com/23urs4.jpg

http://i49.tinypic.com/25883tv.jpg

I brought it back to the store and they told me they will replace the phone but I will have to wait for a maximum of 1 month because the iPhones got out of stock. Infuriating, i know. So I didn't give my phone right away and decided to wait for their stocks and then look up for some answers. I found some saying that you need to just tap your phone to focus, others said to bang it against something hard, which i didnt do. One time I accidentally slipped the phone and it was banged on the keyboard a bit hard but didnt leave scratches. It gave me a mini heart attack though and now here are the samples from the same phone :

http://i49.tinypic.com/hwzhqx.jpg

http://i45.tinypic.com/6942u8.jpg
 

morllaines

macrumors newbie
Jan 23, 2013
1
0
same

This happens when you replace the back cover or disassembly the device.

Remove the fine plastic of the camera sponge ,,this should be work.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.