My browser connects to the internet but mail, itunes, dashboard etc don't

Discussion in 'Mac Basics and Help' started by A3ex, Jan 17, 2010.

  1. A3ex macrumors newbie

    Joined:
    Jan 17, 2010
    #1
    Hi everyone,

    I got a very weird problem. When I connect my computer (Macbook, Mac OS X Leopard) via cable to the router all my applications work with no problem. I can browse the internet, visit the itunes store, receive mail, get updates on my dashboard.

    But when I am connected to the internet via wifi (on the same router) I can still browse the internet while all other apps cannot connect to the internet. Itunes says it cannot connect, mail says it cannot retrieve any mail etc.

    What is wrong??? I have tried on a different router at a friends house. Same thing. Everything works via cable but wirelessly only the browser works and nothing else.

    Thank you very much
    Alex
     
  2. mbestel macrumors member

    Joined:
    Jan 17, 2010
    #2
    First thing to do ...

    First thing to check is the airport config in the Network preference pane.

    - Make sure that it is set to get its IP address via DHCP.
    - Make sure that there are no DNS servers manually configured.
    - Make sure that there are no proxies configured

    Unless, of course, any of these thing are necessary.

    Mark
     
  3. disconap macrumors 68000

    disconap

    Joined:
    Oct 29, 2005
    Location:
    Portland, OR
    #3
    And this may be a "duh" thing, but did you run a permissions repair?
     
  4. A3ex thread starter macrumors newbie

    Joined:
    Jan 17, 2010
    #4
    Mbestler,

    thank you so much for your help. It was the proxies. You are my hero. If you ever in the area you can have free drinks as many as you want ;-)

    I just received 350 emails from the last 3 months.

    For everyone else: Go to your System Preferences -> Network -> Airport -> Advanced -> Proxies -> set "Configure Proxies" to "Manually" and uncheck all boxes in "Select a protocol to configure".

    Thank you too disconap.
     

Share This Page