My Comprehensive Guide/Troubleshooting to 1.1.4 Unlocking - New users READ IT!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iSamurai, Mar 1, 2008.

  1. iSamurai macrumors 65816

    iSamurai

    Joined:
    Nov 9, 2007
    Location:
    ɹǝpun uʍop 'ǝuɐqsı&#
    #1
    Hello all,

    these guides have probably been written a million times by a million people, but this is special ^__^

    I decided to do this because I'd like to give back to the community since a lot of people helped me when i had mental breakdowns (no, not really) when my iPhone was kaputt.

    my phone was broken, no signal, nothing would work, ijailbreak, ziphone (partially working), independence. nothing really worked so I thought it was dead and I was gonna sell it on local listings as an ipod touch. but I eventually solved the problem. read on.


    Reasons to be on 1.1.4
    yadayadaydada. there's a lot of reasons, but the main ones are:
    - fixes the SMS order
    - fixes the time issues
    - more bug fixes
    - should be SDK apps ready
    - official carrier names fit; without scrolling (MIM) - T-Mobile and Vodafone are examples, they scroll and appear as "Voda..." on 1.1.3 and before (even though Vodafone isn't official carrier - hinting that they could be).


    If your iPhone is broken, official SIM is "invalid"
    - enter DFU and restore to 1.1.3. a lot of people have claimed that it'll fix IMEI issues and bricking. No guarantees though.
    - If your SIM that came with the iPhone is invalid (you forgot to take it out while doing an AnySIM unlock), put it back in your phone and do a 1.1.3 restore in DFU.


    Downgrading bootloader from 4.6 to 3.9
    a lot of people described this procedure as "sacrificing" 4.6... but on the reality, there's no chance of breaking your iphone and no difference to the end user. besides, you've got nothing to lose, as the 3G iphone will probably have a newer bootloader.

    what I did:
    - used ziphone 2.2 to downgrade bootloader on 1.1.1
    - waited about 4 minutes.


    Problem with ZiPhone not pairing with iPhone - Enter DFU mode
    your phone has probably just been restored so it's not recognised by itunes. so now you have the "slide for emergency" screen. the solution for ZiPhone to pick up the phone is to:
    - switch it off
    - hold the home button and connect it to the computer simultaneously
    - itunes will find a DFU iPhone
    - ZiPhone should work now.


    Unlocking/Jailbreaking/Activating 1.1.4
    there's really no need for the iphone to be at 1.1.1 and all these downgrades and upgrades. just simply get the 1.1.4 firmware on your computer and do a restore. mac users hold "option" while clicking on the restore button in itunes.

    1.1.4 firmware:
    http://appldnld.apple.com.edgesuite...0226.Sw39i/iPhone1,1_1.1.4_4A102_Restore.ipsw

    if you're just jailbreaking or activating/jailbreaking, follow the tutorial according to your needs.

    There's two ways of doing it. follow either one of them:
    One
    (this is the one I did)
    - put phone in DFU mode. if you have issues with pairing, read above
    - start up ziphone 2.5
    - perform a jailbreak and activation
    - add sources (below)
    - once you can get the springboard, install BSD subsystems.
    - Install the 1.1.4 unlock from iClarified
    - Done!

    Two
    - put phone in DFU mode. if you have issues with pairing, read above
    - start up ziphone 2.5
    - perform a jailbreak, activation and unlock
    - let it do its thing
    - Done!

    Notes:
    - There will be text scrolling on the screen while Ziphone is doing its thing... don't freak out.
    - your bootloader will be downgraded
    - Dialer doesn't crash anymore, but if it does, install appsupport found in iclarified's sources
    - save your contact numbers as +000 XXXXXXXX (country code, phone number) to prevent the Caller ID issue. but install appsupport, as it should solve the problem automatically
    - I suggest that you remove your SIM card (optional, not tested) or insert a different SIM card with pin turned off before unlocking. It could damage your official SIM card that came with it and will say it's "invalid".


    My Installer Sources
    all the default stuff,
    - iphone4.tw/installer
    - iphone4.tw/unlock
    - installer.iclarified.com
    - repo.ispazio.net
    - i.unlock.no
    - community sources


    Tweaks
    - Summerboard - install the 1.1.4 summerboard fix before the 1.1.4SMB is actually released. it is compatible with 1.1.4, but installer won't allow you to install it. so this patch (found in ispazio) will make installer think that it's on a 1.1.3 firmware. uninstall it after you have installed summerboard for 1.1.3.
    - MakeItMine (MIM) - install this before you uninstall the 1.1.4 summerboard patch (installer won't allow it to run) - this app allows you to change the carrier name. the programme was written for 1.0.x to 1.1.3, but it's still working for 1.1.4
    - LocateMe - I don't find this accurate, and if you're on prepaid, don't use it quite often ;)
    - BSDSubsystems
    - Terminal
    - OpenSSH - optional, but you'll need it sooner or later. found in the installer. you'll be able to upload/mod stuff in your phone


    Notes/Common problems
    - Edge is not working - you've gotta put it in the settings :) and it's case sensitive.
    - Google LocateMe didn't work for me, but other people said it works. If it doesn't, use the 3rd party LocateMe.
    - everything should work as normal. mine did.
    - if everything bombed out - like you installed too many random things and has gone wrong, erase all settings (in settings). otherwise restore and redo the whole thing again.
    - Turn OpenSSH off to conserve battery. use NetServices or Services (found in installer) to get it off - some people have reported that it will be turned on when the phone restarts.
    - please note that by performing what I said in this whole post is voluntary and I'm not responsible for anything that's gone wrong, although all the information are correct when I submitted this. by unlocking and doing whatever that apple doesn't want you to do to your iPhone may void your warranty. Warranty is 12 months from the date of purchase, and if handled properly, your phone is unlikely to break in 1 year.

    For more information you can read this: http://www.iclarified.com/entry/index.php?enid=747
    and other tutorials on their sites.


    Conclusion:
    For now, this is the easiest way of unlocking an iPhone and running 1.1.4. I've seen that GeoMod Video, should be easier when it's released.


    Miscellaneous
    My iPhone is:
    - Bootloader 3.9, Baseband 4.04.05, Firmware 1.1.4, 8GB, Week 50, bought from Apple HQ, Cupertino, U.S.
    - On T-Mobile (Germany)/Vodacom (South Africa)
    I've unlocked 3 iPhones now...
    I'd like to thank all those who made the unlock/activation/jailbreak and tutorials that made my phone running nicely without AT&T.
     
  2. tim370 macrumors newbie

    Joined:
    Sep 15, 2007
    #2
    ...dude, awesome effort. should ave a lot of headaches for a lot of people
     
  3. iSamurai thread starter macrumors 65816

    iSamurai

    Joined:
    Nov 9, 2007
    Location:
    ɹǝpun uʍop 'ǝuɐqsı&#
    #3
    and this tutorial should be asprin for many :)
     
  4. hookem12387 macrumors 6502

    Joined:
    Sep 30, 2007
    Location:
    Austin, Texas
    #4
    Is it this complicated for a new out of the box one? Maybe I'm just thinking it's harder than it is
     
  5. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #5
    Sorry for the completely noob question but where do you put the correct settings for edge in. I know the settings but don't know where to put them.
     
  6. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #6
    You have to modify a some files from within the Phone. It seems firmware 1.1.2 upwards get rid of the EDGE preference pane from the phone since several plist files and such in the phone now contain those settings.

    This might be of help to you
     
  7. iSamurai thread starter macrumors 65816

    iSamurai

    Joined:
    Nov 9, 2007
    Location:
    ɹǝpun uʍop 'ǝuɐqsı&#
    #7
    edge: settings > general > network > edge.
     
  8. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #8
    Cheers there were quite a few entries listed in the preferences files given but editing them seemed to work.

    That preference pane does not appear on 1.1.4 (UK) even if you do the preference file edit.
     
  9. iSamurai thread starter macrumors 65816

    iSamurai

    Joined:
    Nov 9, 2007
    Location:
    ɹǝpun uʍop 'ǝuɐqsı&#
    #9
    did you jailbreak (or unlock, idk) it? because I don't think you can change the edge settings if you're on O2 or any other standard carrier.
     
  10. 1rottenapple macrumors 65816

    Joined:
    Apr 21, 2004
    #10
    ziphone seriously rules. Just redid my formerly 1.0.2 iphone and unlocked my dads 1.1.3 to 1.1.4 and it worked flawlessly using ziphone version 2.5. AMazing... I had to donate afterwards!!! When I unlocked my 1.0.2 way back in september, it was complicated with over 19 steps. Now its just one button click.
     
  11. sneaky squirrel macrumors newbie

    Joined:
    Jun 3, 2008
    #11
    thanks so much for all that info iSamurai.

    Can I ask why you chose to downgrade your bootloader from 4.6 to 3.9?

    my iphone is now 1.1.4, upgraded from 1.1.2 OTB
    my baseband is 04.04.05 G
    and my current bootloader is 4.6 (week 46)
    I used Liberty+ to unlock/activate/jailbreak (did this 'successfully' - showed 'enjoy' at the end)

    My problem is that everything on the iphone seems to be fine except that I have a NO SIGNAL status that appears where my carrier (optus australia) should be and I cant make/receive calls or sms.

    Can anyone advise what I should do? Is this a bootload issue? very confused..

    many thanks in advance.
     

Share This Page