My computer won't start up...

Discussion in 'Mac Basics and Help' started by Yondaime111, Feb 14, 2009.

  1. Yondaime111 macrumors newbie

    Yondaime111

    Joined:
    Jan 26, 2009
    #1
    I restarted my computer after installing “IOUSBFamily Log release for Mac OS X 10.5.5 Build 9F33", the grey screen with the apple appeared, but before the "loading circle" thing appeared, my screen dimmed and the "you need to restart you computer" thing came up with all of the different languages. I restarted it, and it did the same thing. I turned it off, unplugged it and plugged it back in, turned it on and it came up again. Luckily, I partitioned my hard drive and installed Mac OS X onto it (incase of an emergency). I am able to boot up using that partition just fine. When It finished booting up, an window saying "Mac OS X unexpectedly quit after restart" or something like that. I opened up Disk Utility and Verified the disk. It said it was OK. I restarted my computer on the problem partition, and it still came up. The next time I booted it up on the "emergency" partition. and copied the error report:

    Code:
    Sat Feb 14 15:54:35 2009
    panic(cpu 1 caller 0x003EB97C): "IOUSBDevice::_RESERVEDIOUSBDevice8 called\n"@/SourceCache/xnu/xnu-1228.9.59/libkern/c++/OSMetaClass.cpp:816
    Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
    0x34497a68 : 0x12b4f3 (0x45b13c 0x34497a9c 0x1335e4 0x0) 
    0x34497ab8 : 0x3eb97c (0x49c500 0x347df280 0x347df280 0x8) 
    0x34497ad8 : 0x347d04d4 (0x347e7118 0x8 0x34497b08 0x3ece8f) 
    0x34497af8 : 0x357b6b66 (0x422d700 0x34497b1c 0x34497b28 0x3f0459) 
    0x34497b28 : 0x357b79ce (0x423a200 0x357bcad4 0x3ca4c20 0x0) 
    0x34497b78 : 0x412976 (0x423a200 0x422e500 0x1 0x3ecd96) 
    0x34497bd8 : 0x414219 (0x422e500 0x423a200 0x42462a0 0x422cce0) 
    0x34497c58 : 0x413a7d (0x422e500 0x41d9380 0x0 0xffffffff) 
    0x34497ca8 : 0x414786 (0x422e500 0x2 0x422e704 0x0) 
    0x34497ce8 : 0x40e528 (0x422e500 0x2 0x1 0x422e500) 
    0x34497d28 : 0x347cec75 (0x422e500 0x2 0x4 0x0) 
    0x34497da8 : 0x354f1e3c (0x422d700 0x420ea00 0x1 0x1) 
    0x34497dc8 : 0x354f1886 (0x420ea00 0x1 0x1 0x0) 
    0x34497e18 : 0x354f13f5 (0x420ea00 0x347e7118 0x3c3fd80 0x10001) 
    0x34497e48 : 0x412976 (0x420ea00 0x422d700 0x1 0x3ecd96) 
    0x34497ea8 : 0x414219 (0x422d700 0x420ea00 0x42468e0 0x4246940) 
    	Backtrace continues...
          Kernel loadable modules in backtrace (with dependencies):
             com.apple.iokit.IOUSBMassStorageClass(2.0.4)@0x357b5000->0x357befff
                dependency: com.apple.iokit.IOUSBFamily(3.1.5)@0x347c0000
                dependency: com.apple.iokit.IOStorageFamily(1.5.5)@0x34d02000
                dependency: com.apple.iokit.IOSCSIArchitectureModelFamily(2.0.5)@0x350d7000
             com.apple.driver.AppleUSBComposite(3.0.0)@0x354f0000->0x354f3fff
                dependency: com.apple.iokit.IOUSBFamily(3.1.5)@0x347c0000
             com.apple.iokit.IOUSBFamily(3.1.5)@0x347c0000->0x347e7fff
    
    BSD process name corresponding to current thread: kernel_task
    
    Mac OS version:
    Not yet set
    
    Kernel version:
    Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386
    System model name: iMac7,1 (Mac-F42386C8)
    Can somebody please help me my hard drive?

    *note: I can browse and open files on the problem hard drive just fine. Also, The OS is 10.5.6
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    You need to remove what you just installed, it may not have been for your machine.
     
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    That is because you installed a file that is meant for 10.5.5 only. you need to reinstall the version for 10.5.6. I had this happen to me, and when i reinstalled the new version it worked just fine.
     
  4. Yondaime111 thread starter macrumors newbie

    Yondaime111

    Joined:
    Jan 26, 2009
    #4
    Thanks for the help, It worked. I suspected that's what I had to do, but I wasn't sure
     
  5. danwongcan macrumors newbie

    Joined:
    Feb 24, 2009
    #5
    I have the same problem, but how can you uninstall and reinstall the correct file?
     
  6. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #6
    there are instructions here
     
  7. Matronix macrumors newbie

    Joined:
    Mar 8, 2009
    #7
    I am having this problem as well. Everytime I boot up my computer it tells me "You need to restart your computer. Hold down the Power button for several seconds or presss the Restart button."

    Where on the blog are the directions to remove the old software installed to fix this issue?
     
  8. jaikob macrumors 6502

    jaikob

    Joined:
    Jul 1, 2008
    Location:
    Freeland, MI
    #8
    Unplug all usb storage devices, boot your mac, and download the 10.5.6 IO kext installer from the developer site.
     

Share This Page