My "died 2 years ago" iMac just Booted!

Discussion in 'iMac' started by marold280, May 31, 2009.

  1. marold280 macrumors 6502

    marold280

    Joined:
    Mar 16, 2008
    #1
    iMac G4 800 Mhz, died about 2 years ago. its been sitting in my room on the top shelf.

    Yesterday i said to myself "oh might as well try it".

    First time, it booted.

    Do iMac G4's have a dodgy power management system ?

    It seems to go on and off all the time. Ive installed Tiger on it and it seems to be stable now.

    Any advice to keep it going ??

    Thanks
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Sounds like power supply is dying. If you have an Apple Store or premium reseller near you pay a visit there and ask.
     
  3. Rankrotten macrumors 6502

    Rankrotten

    Joined:
    Sep 12, 2006
    Location:
    UK
    #3
    I had one of these and sold it to a friend. Two weeks later he called me to say it would not start, took it back and it was totally dead. One week later it booted up as normal and has been running fine for him these past 18 months. Bizarre.
     
  4. J&JPolangin macrumors 68030

    Joined:
    Jul 5, 2008
    Location:
    Thule GL @ the TOW
    #4
    ...another good reason for applecare...
     
  5. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #5
    Even if the OP had AppleCare it would have expired about 2 years ago ;)
     

Share This Page