My dreadful experience with 4.2 software

Discussion in 'Jailbreaks and iOS Hacks' started by shambles76, Jan 25, 2011.

  1. shambles76 macrumors newbie

    Joined:
    Jan 25, 2011
    #1
    Hi MRumours;

    I would like to share my dreadful experience with jailbreaking the iphone 4 running 4.2 software
    Mind you i have jailbroken many iphones but this was my first attempt on 4.2

    I followed the guide given using redsnow. It was doing its thing and the jailbreak went through. well thats what i thought!
    unfortunately cydia logo was white in colour and when i launched it, it quits!
    So i was stuck. Hence my first thought were to restore the phone. Its a brand new phone so i didnt have any data on it.

    During the process of restoring the phone, the phone just went on recovery mode! and there was also an error message.
    So i panic... then i did some research online and found out about umbrella software to kick out the phone on recovery mode. It worked! i was well relieved..

    As i was using my phone, i realize that i couldn't use safari browser. It kept quitting!! So i thought ok, looks like i need to restore the phone again to revamp the whole thing.
    As it was in the process, all of a sudden the phone went on recovery mode again!! So i thought, not to worry cause i have the umbrella software.

    But this time around it didnt work!! The phone just wouldn't get out of recovery mode! then i did some research again and found out that if you jailbreak the phone again, it would kick it out of DFU mode. So i did that and still no joy!
    At this point i panic.. I also read that if umbrella doesn't work, there is nothing much you can do!! gutted!

    So the next day i brought the phone back to my service provider (i bought the phone from the service provider)

    They provide trouble shooting for iphones. They took the phone and reinstall the whole software again. They didn't do it in front of me so im not sure how they did it?? Now my phone is back to normal.

    Just very curious to know how did they do it ? cause i tried so many ways to kick the phone out of dfu mode and no joy

    Out of my head, im think that they use the 4.2 software file to revamp the phone? what program did they use to revamp the phone? I cant seem to get this info online. Any one here knows? I would like to be able to learn this in case i ever get into this dilemma again.

    Anyone knows?

    Thank you for your time and advise
     
  2. Jkazmeyer macrumors regular

    Joined:
    May 2, 2010
    Location:
    Madison TN
    #2
    All they did was restore via iTunes. It sounds like you didn't reboot your device with redsnow after installing cydia. Redsnow is tethered on your device, so you need to use redsnow to boot each time you power off or reboot. Once you've gotten it jailbroken, before you open cydia, use redsnow to "just boot tethered right now" and follow the instructions. You must do that each time. If you reboot or turn off power you'll need to use redsnow to kick it out of the boot loop.
     
  3. shambles76 thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #3
    Restore via itunes? that's the first thing i did and it didnt work! it kept going back into recovery mode. i even tried restoring the phone on a different computer using itunes and still didnt work.
     

Share This Page