My External HD disappeared

Discussion in 'Mac Basics and Help' started by TonyP53, Apr 7, 2013.

  1. TonyP53 macrumors newbie


    Apr 7, 2013
    North Andover MA
    Here's the deal. i have a 27" iMac running 10.8.3. i store most data (all except mail) on a 3T WD external HD. i use ccc to keep a clone of this drive on a 3T Seagate (fortunately).

    Not sure if this is related but...yesterday i lost access to my iPhoto library (on WD) after it froze while adding a video to the iPhoto library and i had to force quit that app. i followed directions and ended up having to rebuild the library which solved that problem.

    today, i did a restart and when everything fired up the 3T did not appear on my desktop or in finder. not unusual. what i learned is the two 3T's and a 1T external i use for time machine draw more power than the usb system can support. when this issue appears and ut has for months all i do is unplug and replug the offending drive (it always is the 3t WD) and bingo it appears and is accessible.

    Not so today.

    so far i have verified my finder preferences and shut down moving the WD usb connection to each of the other usb ports all with no luck. i did this with no other usb devices connected.still no luck.

    i have tested usb ports with the scanner and they appear to be working. and finally i tested the 3T WD wire by using it to connect the 3T seagate clone and it works. i did the reverse using the seagate wire on the WD. no luck.

    and throughout all of this the WD has it's light on, which flashes when i plug it into the iMac.

    i am concluding that the WD is fried. have i missed anything? what do you think?

    thanks for sharing your experience and knowledge with me.

    be well

  2. RedCroissant Suspended

    Aug 13, 2011
    Is usb 2.0 the only I/O on this drive that you can test? Have you tried connecting it to another machine to see if it is mounted/recognized?

    The reason I ask is because I had this problem once on my 1TB MyBook Studio and what I did was simply shut it down by holding down the power button and continued that for about a minute. Then I unplugged it from the outlet and from the machine. I just waited another minute, reconnected it; and no problem since.
  3. AcesHigh87 macrumors 6502a


    Jan 11, 2009
    New Brunswick, Canada
    Is the drive still being read in Disk Utility? Even if it won't physically mount when it's plugged in if the drive is operating Disk Utility should pick it up and add it to the side panel.

Share This Page